Dynamic Routing do not delete records after expiration date

1 Like

That is already happening with me in V3 too! but you have the call to be completed and besides the duplication of the numbers with the main tenant with the customer tenant

I haven’t tenants and you can see, that same calls completed 3 days ago.

Have you checked this is enabled as in below image?

You can see it on top post

I thing with this setting all record must deleted after 24 hour automatically

Yes after 24 hours if not used or if you enable Used Recording. and it could be a bug!

Try executing the script below manually.

 /usr/share/vitalpbx/scripts/dynamic_routing "maintenance"

Keep in mind that the CRON service must be running for this script to be executed automatically.

Thank you, it’s work fine

Our Vitalpbx a multi-tenant, is that command I just need to run once or repeat it for each tenant (in multi-tenant system), even the maintenance addon is installed and enabled? do I have to create a corn job for each hour for the maintenance schedule or set it to what’s best value to? and do we make it for main tenant only and will work on all tenants, or we have to do it for each tenant separately?

The Cron profile/schedule is configured globally.

But the Status(Enabled/Disabled) is configured per tenant.

The same script will execute the maintenance for all the tenants, but the option “Enabled” must be set to “Yes” in the desired tenants.

1 Like

I not have multi-tenant
When I try executing the script below manually (/usr/share/vitalpbx/scripts/dynamic_routing “maintenance”), it’s work fine and CRON service is running, but script not to be executed automatically.