Connection to the server cannot be established pop-up

We updated VitXi two days ago to 1.1.0 and since then we are getting this pop-up randomly.

We have updated last night to 1.1.0-2 and today in the morning to 1.1.0-3.

We cleared cache, and this is still happening. Nothing showing in the Asterisk Console while this is happening.

It pops up for a couple of seconds and then disappears. Here’s a screenshot with the (chrome) browser console opened while it popped-up.

(Note: This does not drop phone calls)

image

verify that the FQDN is configured in the hostname in the option Admin/Network / Network Setting / General
sample: hostname: servername.domain.com

1 Like

I’ll verify, but again, prior to the update it worked fine.

Additionally, how should we go about this when using multiple subdomains?

1 Like

When the hostname of your PBX changes, you can use the “PBX Settings” module, in which you can establish the connection to the PBX.
image

That’s great for single tenant. How would you handle multiple subdomains?

Perhaps if we can set the PBX hostname to company.com and then allow connections to *. company.com (for example client1.company.com client2.company.com etc etc)

1 Like

OK, the actual PBX hostname was pbx1.company.com. In VitXi, the host was set to localhost. So I changed it to pbx1.company.com.

End-users don’t see this pop-up anymore, but checking the browser console I do see still Socket is closed. Reconnect will be attempted in 5 seconds. every here and there. But when logged in as admin, you still get this pop-up.

Something must’ve changed in the recent updates that broke this.

Hello Sir!

We are performing the relevant tests on our development servers. As soon as we fix the issue, we will release a new version.

Best regards!

1 Like

Hi!

A new version of VitXi has been released.

You can update and perform the necessary tests.