Connect an external Drive in VitalPBX4 HA

Continuing the discussion from How to connect an external drive (NAS or Storage Server) in VitalPBX to store the recordings?:

I have no problem mounting the shared directory in which the audio are going to be recorded. I’m able to create file or directories.

When running this commands, everything seems to ve fine.:
cd /var/spool/asterisk/
ln -s /nfs/recordings/ monitor
chown -R asterisk:asterisk monitor

The symbolic link was create inside /var/spool/asterisk/monitor/ and the audios files keep being save on /var/spool/asterisk/monitor

Remove the symbolic link
cd /var/spool/asterisk/
rmdir monitor
ln -s /nfs/recordings/ monitor
chown -R asterisk:asterisk monitor

So far, is was looking ok, but when I made a test call the audio did not get recorded (both extension had enable recording incoming/outgoing/internal)

I check the full log for that call , and it shows the directory in which the audio is going to be saved, no error
[2023-05-17 08:40:44] WARNING[80242][C-00000001] file.c: Unable to open file /var/spool/asterisk/monitor/2023/05/17/084036-LOCAL-Q10-101-102-1684334436.0.wav: Permission denied
[2023-05-17 08:40:44] ERROR[80242][C-00000001] app_mixmonitor.c: Cannot open /var/spool/asterisk/monitor/2023/05/17/084036-LOCAL-Q10-101-102-1684334436.0.wav

Asterisk needs to be able to write to the folder, otherwise you get the permission errors you are getting.

chown asterisk:asterisk /var/spool/asterisk/monitor
chown asterisk:asterisk /mnt/monitor

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.