Can't Register a Trunk/Extension

Hello!

I can’t register a trunk or extension, for a moment it registered but with the same configuration dont work anymore.

In the extension case, when it work i had to specify the server sip port on softphone configuration, example: myvitalpbx.com:5062 and if i don’t specify that says “authentication failed”.

At this moment i’m unable to register an extension, my softphone only says “no connected”.

Same thing with the trunk, i’m using the same setup that once worked.

It does not seem to be a problem of fail2ban service.

Are you creating your extension as sip or pjsip?

Hi,

I’m creating my extension as sip. It recently stopped working.

In the actual version if it is SIP the port is 5062. You have to include the port on the device to be registered and change it from 5060 to 5062

I do it, but although don’t say “authentication failed” still says “no connected”. I don’t get it, because it worked for a couple of weeks.

Check your trunk settings, in my case I get that message when I have something wrong in my outbound registration settings

If you messed with the transports you need to restart asterisk

I performed a restart to virtual machine and still not working. After update VitalPBX to 3.1.1-2 same problem. It’s weird because extension/trunk both things are not registering. I will check and if i find the issue i let to know you.

Are you using PJSIP?

Try entering to the Asterisk CLI, and execute the command below.

module reload res_pjsip.so

Check if the command above returns an error.