Cannot install OpenVPN

I have tried multiple times to install OpenVPN and failed on one installation.
I get a message “The addon has not been installed”.
I installed several other addons succesfully.
Is there anything I can do?

You can try installing the add-on manually from the Linux CLI.

yum install vitalpbx-openvpn -y

I tried it and I got an error that I had to install applydeltarpm.
I did that and then I got another error that yum could not find php-pecl-zip-1.19.0-1.el7.remi.7.2.x86_64
I tried to yum install php-pecl-zip and got the next error.

No Presto metadata available for vpbx-base
php-pecl-zip-1.19.0-1.el7.remi FAILED [Errno 14] HTTP Error 403 - Forbidden ] 0.0 B/s | 0 B --:–:-- ETA
Trying other mirror.

This commonly happens due to Network restrictions.

Is your server a self-hosted server?

Do you have some kind of proxy in the Network?

The server is self hosted but uses no proxy.
There me be an issue with the DNS server, since we are using an internal one and not the or, but I wonder why it can install other addons and not this particular one.

I manually downloaded php-pecl-zip-1.19.0-1.el7.remi.7.2.x86_64.rpm
I installed libzip5 and then installed the rpm.
All is ok now.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.