Call Dropped after 30 seconds from Vitalpbx Connect to WebRTC user internally over PJSIP with TLS

res_pjsip_sdp_rtp.c:146 rtp_check_timeout: Disconnecting channel ‘PJSIP/102_1-00000049’ for lack of audio RTP activity in 30 seconds
Even though call gets connected and both users can hear each others

Hello Sir,

In case your PBX is behind a one-to-one NAT, you must set the local IP and the public IP in the ICE Host Settings section within the RTP Settings module.

Also, ensure to enable ICE SUPPORT and disable Strict RTP.


Thank you, Maynor i will check it and update you if it fixed my issue

1 Like

Hello Maynor, below are the screen shots regarding my settings can you review them and guide me where i am doing mistake

PjSIp Device Profile

WebRTC Device Profile

PJSIP Settings

RTP Settings

You can make the following adjustments to the WebRTC profile:

Max Video Streams: 35
Max Audio Streams: 35
RTP Keepalive: 1
RTP Timeout: 0
DTLS Verify: Fingerprint
Direct Media: No
Media Encryption Optimistic: No

If you are using VitXi, you can remove the STUN server that has been set in RTP Settings, as VitXi internally establishes it in its settings.

I am calling internally from Vitalpbx Connect user to a Vitixi User and there i am getting this issue

Thank you so much Maynor really appreciated finally i have done a successful call internally from VitalPBX Connect to VITIXI user over secure PJSIP profile. Thank you so much

1 Like

Perfect!, I’m glad to help!!

Much appreciated, Thank you

1 Like