Bunch of XXXX on the background of Yealink Phones

Hello, I cannot find where and how I get a bunch of XXXX in the background on my T54W (see circled in red):

Obviously its supposed to be the date and time but it’s not displaying properly.

Not sure where in the provisioning file I can change, correct or disable this.

Thank you

What version of VitalPBX are you running?

Hello Miguel,

Is V4 ready for production?

Yep! V4 is production ready.

Super, DigitalOcean Market place only offers V3.2.4-2 so I was wondering, let’s get back to the current topic.

I will spin up a new Droplet with V4 and test again to see if the issue persists then.

Spin up a Debian 11 VM and install using the follwoing instructions: How To Install A PBX System In 2023 With VitalPBX 4.0

Ok so I found the issue for the XXXX as per my screenshot.

There is an error in the template creation for the T54W (maybe other models that rely on the same template like maybe the T53W and T57W.

In the template, you have this line:

local_time.date_format = {{ $dateFormat ?? 0 }}

(located in PBX → Provisioning ->Templates → CUSTOM tab)

And in the “GUI SETTINGS” tab of the “Provisioning Templates” page, you get this dropdown:

Dropdown gives you 10 options but there can only be 7 or custom. (0 to 6, or 20 for custom.

(screenshot from the T54W WUI)

In my case, I selected : “YYYY MM DD” (the last option in the dropdown), and the PBX created this variable:

Unfortunately, “9” is not a valid variable and the phone makes XXXX XXX XXXX in the background as per my screenshot.

To any mods or admin, kindly move this thread to the “Bugs”.
This issue is with VitalPBX v3.2.4-3 and also v4.0.3-5

Thank you

1 Like

To any mods or admin; Kindly move this thread to “Bugs”

Thank you

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.