Backups not running

We just realized our backups have not run in a long time. It is set up per the WiKi post below and we set up a cron job for every day at 2am using the template so any ideas what to check?

Can you please share a screenshot of the backup and from the cron job?

Also, try running vitalpbx check-integrity to fix any permission issues.

Sorry for the daylay I was out of the office. Screenshots attached.

The folder or file “/var/lib/vitalpbx/static” had the group “none” instead of “apache” (fixed up)
Folder “/var/lib/vitalpbx/static/backup” didn’t exist (fixed up)
The folder or file “/var/lib/vitalpbx/static/backup” had the permissions 3325 instead of 2775 (fixed up)
The folder or file “/var/lib/vitalpbx/static/backup” had the owner “root” instead of “apache” (fixed up)

That might have done it.

You maybe forgot the thanks?

Well I was waiting to confirm the issue was fixed, I just checked it was not. Do you have any idea what the issue could be?

Just bouncing this as we still don’t have a solution.

Do you get any errors when trying to generate the backup from the GUI?

Running a manual backup works without issue.

Have you checked for any cron errors?

I’m having the same issue with my Vital 4 now that you mention it. I’ll check these @mo10 and thank you appropriately now ahead of time pending the results… Thank you :slight_smile: lol @PitzKey

OK, so here is a possible quick fix as I tried it and it worked for me…

Have you tried creating a new cronjob? Delete the current cronjob… I created a new cronjob and it works. I’m guessing with the restore from Vital3 to Vital4, something did not sit well.


I’ll try that but we are still on 3, large production system so will be a while before we upgrade to 4.


I’m sorry, for some reason I assumed your were on Vital4. I would still give that a try. I would create a quick cronjob such as the one that happens every 5 minutes just to test and see if the cronjobs are occurring. It would be nice to fix the profile you already have in place and answer as to why it stopped working but, this would be a quicker fix. Sometimes I myself am not happy enough with fixing something without knowing the cause of the problem.



1 Like

Yeah I’ll give it a try tomorrow when I get in the office and post my results.

So I created a new 30 minute backup chron and that worked fine. Deleted and recreated the 2am cron job and will see if that fixes it, fingers crossed.

Hopefully it goes well. I will say my midnight and 12PM crons did go as scheduled today.


Does this happened after restoring a backup?

Not in my case, this is our original install.

That did it, backup ran correctly last night, thanks for the help!