Auto Answer with Follow Me


In previous versions of vital PBX there was a line in the dialplan that checked if the extension has follow me enabled before executing auto answer (otherwise follow me wouldn’t work, as the extension answers the call before it rings the follow me destination), but it was removed in Vital PBX 3,

I added the following line in the sub-local-dialing context (after priority 27 which checks for the SKIP_AA variable), which fixed the issue, but the problem is that i have to manually add it after each update, can it please be included in following updates?

same => n,GotoIf($["${SRC_APP:0:2}"="FW"]?check-hd)

Thank you!

1 Like


Thanks for reporting it. We will do a couple of tests, and hopefully, this will come ironed out in the upcoming versions of VitalPBX.

1 Like

Hey @EINM,

In the file “/etc/asterisk/vitalpbx/extensions__20-baseplan.conf” look for the context sub-local-dialing and change the line below.

same => n,ExecIf($[$[$[$["${ANSWER_MODE}"="intercom"]&$["${CALL_TYPE}"="1"]]|$["${FORCE_INTERCOM}"="yes"]]&$["${DESTINATION_STATE}"="NOT_INUSE"]]?Set(EXEC_AA=yes)) ;Flag for Auto-Answer


 same => n,ExecIf($[$[$[$["${ANSWER_MODE}"="intercom"]&$["${CALL_TYPE}"="1"]]|$["${FORCE_INTERCOM}"="yes"]]&$[$["${DESTINATION_STATE}"="NOT_INUSE"]&$["${DB(${TENANT}/diversions/${CALL_DESTINATION}/FWM/enable)}"="no"]]]?Set(EXEC_AA=yes)) ;Flag for Auto-Answer

Save the file and do a reload of the dialplan.

asterisk -rx"dialplan reload"

I’ll be looking forward to your comments.

1 Like

Thank you @miguel, it’s working!
Hope it’ll be included in future releases

1 Like