Assisted transfer audio problem

I made a drawing to illustrate my topology.

image

receive a call and it is directed to extension 204 audio ok

image

receive a call and it is directed to extension 205 audio ok

image

internal call from 204 to 205 or from 205 to 204 audio ok

image

receive a call and it is directed to extension 204 and assisted transfer to extension 205 no audio in transfer assisted.

image

after disconnection to extension 204, completing the transfer of the external call to extension 205

audio returns to normal

the problem only occurs in the connection between extension 204 and 205

image

using the blind transfer feature #1 we have no problems

two observations the extensions are all behind a NAT.

analyzing the packet capture at the time of the error connecting from extension to extension in assisted transfer, NAT is not being done in only one of the directions

Removed the previous post.

Please do not tag anyone that isn’t involved in the conversation.
This is a community forums, people will participate if they choose to.

Please and thank you

ok sorry, I’m just desperate because I have this bug on 5 clients at the same time…

and something in my opinion so serious that it should be given more importance…

but that’s okay… if no one speaks up, I’ll change the solution to the clients…

When the attendant transfer happens, with what IP does asterisk negotiate audio?

In the PJSIP Profile, try disabling or enabling the “Direct Media” parameter. Additionally, disable the option “Disable NAT Direct Media.”

Remember to define the NAT settings in the PJSIP Settings module, and in the RTP Settings module, try disabling all the checkboxes but the “ICE Support” checkbox because it is required for WebRTC.

none of these options worked

but I managed to solve it by changing the parameter below in the SIP profile

image

I changed from “Yes, If no Nat” to Use Update

1 Like

I thought you were using PJSIP. My recommendations were based on PJSIP protocol, not SIP.

Sorry I forgot to mention this…

I’m not using SIP the PJSIp is disabled.

I’ll even take advantage of it, and then in a test environment enable pjsip and simulate this same environment to see if there’s the same problem and I report it here.

You should make a plan to migrate to PJSIP. Asterisk 19 is built without ChanSIP by default.

guys updating the situation

SIP protocol after updates to USE Update I’m with the following behavior that I couldn’t solve.

External call ----> extension answers ----> ok
External call ----> extension answers ----> assisted transfer “*2” → ok
External call —> queue → outgoing calls normally, but when directing to an agent the call is ended.

when checking the logs I found the following.

> 0x7f0c400ee700 -- Strict RTP learning complete - Locking on source address 200.201.197.137:7908
[2021-11-06 12:41:38] WARNING[2168]: chan_sip.c:4143 retrans_pkt: Retransmission timeout reached on transmission uEk0B4b7cJ2c8114b17c3c35101394b39830c2e980@200.201.197.137 for seqno 102 (Critical Request) -- See https://wiki.asterisk.org/wiki/display/AST/SIP+Retransmissions
Packet timed out after 6399ms with no response
[2021-11-06 12:41:38] WARNING[2168]: chan_sip.c:4167 retrans_pkt: Hanging up call uEk0B4b7cJ2c8114b17c3c35101394b39830c2e980@200.201.197.137 - no reply to our critical packet (see https://wiki.asterisk.org/wiki/display/AST/SIP+Retransmissions).
    -- Stopped music on hold on SIP/imp27713995-000000de

the ip address that appears in the log is the ip address of the extension that is ringing and when the call is answered, it is terminated.

when I return the parameter to “Yes, If no Nat”

External call ----> extension answers ----> ok
External call ----> extension answers ----> assisted transfer “*2” → No audio call between extensions → after transferring external call the audio returns
External call —> queue → ok.

already according to the guidelines valid the same tests with the PJsip channel

extension to extension connections ----> ok (note the two extensions are in different networks)
external call —> direct to extension -->> ok
external call —>>> queue answers —> transfer to agent —>> audio only one way.

image

In PJsip Chanel

external call —>> direct to extensio —> assisted transfer *2 → ok

Remember to define your NAT settings on PJSIP and SIP.

If your server is self-hosted or if it has an internal IP, you have to define it as a Local Network.

server is cloud with direct public ip no internal IP.

Try enabling the “Support Path” option in the PJSIP Profile. Additionally, assign the PJSIP profile to your trunk!

later I redo the tests changing this parameter and inform here. Thanks