Anyone have Alert Info Working with PJSIP?

Can anyone confirm Alert-Info is working with PJSIP in current version, I have the string set on my inbound routes but phones are acting like they are not getting it. I have set up these phones on another PBX software before and they worked great so I’m leaning towards it being VitalPBX. I see a number of previous posts saying it did not work with PJSIP but that it would be fixed in the “next update” so I am looking for confirmation it was fixed before I pull my hair out.

Try using SNGREP to verify if the PBX is sending the Headers.

I’ll have to look into the SNGREP tool, we came from another PBX system that had packet capture and such built in so we aren’t familiar with stuff like this.

Well after a quick crash course I do see an “Alert-Info: pbx-external” which is the info I added. I guess my next question is does anyone have this working with Grandstream GRP phones, maybe they handle it correctly with SIP but not with PJSIP.

Did you configure the phone to recognize this alert info? If so, if you do a packet capture on the actual phone, do you see the alert info there?

I did set up the phone, specifically it was already set up and working on another PBX and we did not change anything on the config but the server.

I’ll try a packet capture from the phone.

I have it working with this on inbound routes:
image

I use that with Gigaset Phones and PJSIP and it is working.
One the Gigaset side i also need to use all of that:

info=alert-external

Actually it is this but that is a different thing (has todo with Gigaset). Internal for External and External for Internal.

info=alert-internal

So I did a packet capture from the phone and the Alert-info header does appear to be in the data the phone received

Alert-Info: pbx-external

Scratching my head now because the phones worked on our old PBX setup but I’ll have to look into issues with the phone now as the only change was from SIP to PJSIP and the data appears to be sending properly.

Please share the exact part of the sip trace. Also send screenshots of the inbound route and it’s Alert Info!

Can you show us what you configured on the phone to look for the alert-info?

Phone Setting
Route Setting
SIP trace info will be in next post.

Capture from phone.

Frame 292: 1412 bytes on wire (11296 bits), 1412 bytes captured (11296 bits)
Ethernet II, Src: eacAUTOM_33:33:33 (00:e0:67:33:33:33), Dst: Grandstr_2d:13:0a (c0:74:ad:44:44:44)
802.1Q Virtual LAN, PRI: 0, DEI: 0, ID: 0
Internet Protocol Version 4, Src: 111.111.111.111, Dst: 222.222.222.222
User Datagram Protocol, Src Port: 5060, Dst Port: 54906
Session Initiation Protocol (INVITE)
Request-Line: INVITE sip:101@222.222.222.222:54906 SIP/2.0
Message Header
Via: SIP/2.0/UDP 111.111.111.111:5060;rport;branch=z9hG4bKPj097ff4a8-da88-408b-ac1e-f50c3f68724b
From: “UTS Brian Cook Cell” sip:7726332507@111.111.111.111;tag=e74893b3-bf32-4eee-bd45-312ca0466c4e
To: sip:101@222.222.222.222
Contact: sip:asterisk@111.111.111.111:5060
Call-ID: b10650b0-c9e8-48f5-b426-7dbf21439582
[Generated Call-ID: b10650b0-c9e8-48f5-b426-7dbf21439582]
CSeq: 10590 INVITE
Allow: OPTIONS, REGISTER, SUBSCRIBE, NOTIFY, PUBLISH, INVITE, ACK, BYE, CANCEL, UPDATE, PRACK, MESSAGE, REFER
Supported: 100rel, timer, replaces, norefersub, histinfo
Session-Expires: 1800
Min-SE: 90
P-Asserted-Identity: “UTS Brian Cook Cell” sip:7726332507@111.111.111.111
Remote-Party-ID: “UTS Brian Cook Cell” sip:7726332507@111.111.111.111;party=calling;privacy=off;screen=no
Alert-Info: pbx-external
Call-Info: pbx-external
CALL-TYPE: IN
APPLICATION: NONE
Max-Forwards: 70
User-Agent: VitalPBX
Content-Type: application/sdp
Content-Length: 404
Message Body

(Obviously info has been sanitized)

And now please the SIP-trace from VitalPBX with the Alert-Info.
+some info from SNGREP maybe.

FYI:
I just tested with Fanvil X6U and everything is working just fine (PJSIP).

image
image

Grandstream issue with PJSIP?
Try with “external” instead of “pbx-external” in all fields.

Could you please try with Chan_SIP for testing?
Not sure if true: for Alert-Info on Chan_SIP “info=pbx-external” might be needed in inbound route of VitalPBX.

That was something I actually suggested above that its a specific PJSIP & Grandstream issue as this worked with the same phone on our old system which was SIP only.

I already tried just “external” troubleshooting before I made this post.

I’ll get some SNGREP traces this afternoon if things slow down, short a tech for the week so its busy.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.