VitalPBX 4: Issue while saving data after Branding modification

Hello dear team

We are facing issue on V4 while trying to modify the Branding section!

Can you please assist?

Best regards

Which version of VitalPBX?


vitalpbx check-integrity

Hello dear

Thanks for your feedback

The result of tha command gave :

No Issues found


I believe I ran into this same situation. Although not always practical, have you tried restarting the server?


1 Like

hello dear @ferher1

Let me try


I restarted the server but no chance, same issue

Best regards


Just to make sure, you have a licensed version of VitalPBX 4? I know that some of the branding takes effect with a license while some of the branding doesn’t need a license.

1 Like

Looks like this is only an issue for multi tenant.

1 Like

Yes, we have a Career Plus licence!

Are you running the latest VitalPBX 4?

Are you applying the branding settings from the main tenant? Remember that branding add-on it’s not multi-tenant.

1 Like

Hello dear @miguel

We are running Version 4.0.1 and we are connected as Admin on Main Tenant

And bellow is what we are exactly trying to change

When we click on SAVE

Check the folder permissions of your installation. I’ve tried in a brand new installation, and I had no issues.

1 Like

@miguel sure

Which permissions should we give? 777 ?

You should never give permission 777 to a public folder.

According to the installation file of the branding add-on, applying these commands should be enough

chown www-data:www-data /usr/share/vitalpbx/www/resources/css/branding
chown -R www-data:www-data /usr/share/vitalpbx/www/resources/css/branding
1 Like

Hello dear @miguel

Thanks a lot as this solved the issue

Best regards

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.