# V4 outbound not working contact URI invalid

**URL:** https://forums.vitalpbx.org/t/v4-outbound-not-working-contact-uri-invalid/3686
**Category:** VitalPBX
**Created:** [January 26, 2024, 12:32pm UTC](https://forums.vitalpbx.org/t/v4-outbound-not-working-contact-uri-invalid/3686 "2024-01-26T12:32:57Z")
**Posts on this page:** 6
**Page:** 1

<div class="post-metadata">

### Author: ![Shield001](https://forums.vitalpbx.org/letter_avatar_proxy/v4/letter/s/bbce88/32.png) [@Shield001](https://forums.vitalpbx.org/u/Shield001)
#### Post date: [January 26, 2024, 12:32pm UTC](https://forums.vitalpbx.org/t/v4-outbound-not-working-contact-uri-invalid/3686/1 "2024-01-26T12:32:57Z")

</div>

Having all kinds of issues trying to get VitalPBX working. Followed the directions but seems to be for V3

> **[VitalPBX: Configuring Your VitalPBX | Telnyx Support](https://support.telnyx.com/en/articles/5754445-vitalpbx-configuring-your-vitalpbx)**
>
> Learn how to configure VitalPBX to work with Telnyx using either credentials (user/pass) or IP authentication.

Specifically it states the contact and match should be [sip.telnyx.com](http://sip.telnyx.com) but I get the following error.

[2024-01-25 11:05:38] ERROR[1497]: res\_pjsip/location.c:615 permanent\_uri\_handler: Contact uri or hostname length exceeds pjproject limit or is not a sip(s) uri: [sip.telnyx.com](http://sip.telnyx.com)  
[2024-01-25 11:05:38] ERROR[1497]: config\_options.c:798 aco\_process\_var: Error parsing [contact=sip.telnyx.com](http://contact=sip.telnyx.com) at line 312 of /etc/asterisk/vitalpbx/pjsip\_\_50-1-trunks.conf  
[2024-01-25 11:05:38] ERROR[1497]: res\_sorcery\_config.c:422 sorcery\_config\_internal\_load: Could not create an object of type ‘aor’ with id ‘Telnyx1’ from configuration file ‘pjsip.conf’

Another post said it should be sip:sip.telnyx.com but get a different error.  
[2024-01-25 11:13:01] ERROR[1497]: netsock2.c:303 ast\_sockaddr\_resolve: getaddrinfo(“sip”, “[sip.telnyx.com](http://sip.telnyx.com)”, …): Servname not supported for ai\_socktype  
[2024-01-25 11:13:01] ERROR[1497]: res\_pjsip\_endpoint\_identifier\_ip.c:553 ip\_identify\_apply: Identify ‘Telnyx1’ failed when adding resolution results of ‘sip:sip.telnyx.com’  
[2024-01-25 11:13:01] ERROR[1497]: res\_sorcery\_config.c:422 sorcery\_config\_internal\_load: Could not create an object of type ‘identify’ with id ‘Telnyx1’ from configuration file ‘pjsip.conf’  
[2024-01-25 11:13:01] NOTICE[1497]: res\_sorcery\_config.c:434 sorcery\_config\_internal\_load: Retaining existing configuration for object of type ‘identify’ with id ‘Telnyx1’  
[2024-01-25 11:13:01] NOTICE[1497]: sorcery.c:1348 sorcery\_object\_load: Type ‘system’ is not reloadable, maintaining previous values

Also getting the following other errors on reload. one concern is its showing that dialplan.conf error at line 3384/3385 even though the file only has 575 lines. We don’t have any \_ in our extension

[2024-01-25 11:13:01] WARNING[7698]: pbx\_config.c:1879 pbx\_load\_config: The use of ‘\_.’ for an extension is strongly discouraged and can have unexpected behavior. Please use ‘_X.’ instead at line 3384 of /etc/asterisk/vitalpbx/extensions\_\_50-1-dialplan.conf  
[2024-01-25 11:13:01] WARNING[7698]: pbx\_config.c:1879 pbx\_load\_config: The use of '_.’ for an extension is strongly discouraged and can have unexpected behavior. Please use ‘\_X.’ instead at line 3385 of /etc/asterisk/vitalpbx/extensions\_\_50-1-dialplan.conf  
[2024-01-25 11:13:01] NOTICE[7698]: app\_queue.c:9573 reload\_queue\_rules: No queuerules.conf file found, queues will not follow penalty rules  
[2024-01-25 11:13:01] ERROR[7698]: res\_sorcery\_config.c:328 sorcery\_config\_internal\_load: Unable to load config file ‘geolocation.conf’

---

<div class="post-metadata">

### Author: ![miguel](https://forums.vitalpbx.org/user_avatar/forums.vitalpbx.org/miguel/32/415_2.png) [@miguel](https://forums.vitalpbx.org/u/miguel)
#### Post date: [January 26, 2024, 12:34pm UTC](https://forums.vitalpbx.org/t/v4-outbound-not-working-contact-uri-invalid/3686/2 "2024-01-26T12:34:20Z")

</div>

Sharing your current trunk configurations might help to identify the issue in your configurations. Instructions for V3 also work on V4 because they are not too different.

---

<div class="post-metadata">

### Author: ![Shield001](https://forums.vitalpbx.org/letter_avatar_proxy/v4/letter/s/bbce88/32.png) [@Shield001](https://forums.vitalpbx.org/u/Shield001)
#### Post date: [January 26, 2024, 2:08pm UTC](https://forums.vitalpbx.org/t/v4-outbound-not-working-contact-uri-invalid/3686/3 "2024-01-26T14:08:34Z")

</div>

Here’s the screenshot and seems identical to the instructions, other than the identify by which we’ve tried a few things. Getting this error on reload

[2024-01-26 09:05:50] ERROR[122097]: config\_options.c:798 aco\_process\_var: Error parsing [contact=sip.telnyx.com](http://contact=sip.telnyx.com) at line 313 of /etc/asterisk/vitalpbx/pjsip\_\_50-1-trunks.conf  
[2024-01-26 09:05:50] ERROR[122097]: res\_sorcery\_config.c:422 sorcery\_config\_internal\_load: Could not create an object of type ‘aor’ with id ‘Telnyx1’ from configuration file ‘pjsip.conf’  
[2024-01-26 09:05:50] NOTICE[122097]: res\_sorcery\_config.c:434 sorcery\_config\_internal\_load: Retaining existing configuration for object of type ‘aor’ with id ‘Telnyx1’  
[2024-01-26 09:05:50] NOTICE[122097]: sorcery.c:1348 sorcery\_object\_load: Type ‘system’ is not reloadable, maintaining previous values  
[2024-01-26 09:05:50] ERROR[122097]: res\_pjsip\_outbound\_registration.c:1976 sip\_outbound\_registration\_apply: Server URI or hostname length exceeds pjproject limit or is not a sip(s) uri: ‘Telnyx1’  
[2024-01-26 09:05:50] ERROR[122097]: res\_sorcery\_config.c:422 sorcery\_config\_internal\_load: Could not create an object of type ‘registration’ with id ‘Telnyx1’ from configuration file ‘pjsip.conf’

 ![Screenshot 2024-01-26 090721](https://forums.vitalpbx.org/uploads/default/original/2X/f/f160f1e25b1250bf1b1802f3accf994352bdb69e.png)

---

<div class="post-metadata">

### Author: ![miguel](https://forums.vitalpbx.org/user_avatar/forums.vitalpbx.org/miguel/32/415_2.png) [@miguel](https://forums.vitalpbx.org/u/miguel)
#### Post date: [January 26, 2024, 4:09pm UTC](https://forums.vitalpbx.org/t/v4-outbound-not-working-contact-uri-invalid/3686/4 "2024-01-26T16:09:14Z")

</div>

I would recommend changing the password because now is public for everyone.

About your settings, the Telnyx screenshots are wrong. You must omit the parameters Contacts, Client URI, and Server URI.

---

<div class="post-metadata">

### Author: ![Shield001](https://forums.vitalpbx.org/letter_avatar_proxy/v4/letter/s/bbce88/32.png) [@Shield001](https://forums.vitalpbx.org/u/Shield001)
#### Post date: [January 26, 2024, 4:35pm UTC](https://forums.vitalpbx.org/t/v4-outbound-not-working-contact-uri-invalid/3686/5 "2024-01-26T16:35:08Z")

</div>

Just changed thanks! Looks like it registered now and no errors so will further test.

So these instructions on the attachment are wrong.

 ![](https://forums.vitalpbx.org/uploads/default/original/2X/6/6fafecffecd81e641e0e3970b63240970a9fa1ce.png)

---

<div class="post-metadata">

### Author: ![system](https://forums.vitalpbx.org/uploads/default/original/1X/672b458a1d454755270c2c16adc5316b641c3c6a.png) [@system](https://forums.vitalpbx.org/u/system)
#### Post date: [February 25, 2024, 4:36pm UTC](https://forums.vitalpbx.org/t/v4-outbound-not-working-contact-uri-invalid/3686/6 "2024-02-25T16:36:02Z")

</div>

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.
