Unable to permanently disable intrusion detection

I want to permanently disable Intrusion detection in GUI but after each reboot I find it being turned on again. Fiddling around manually with the failtoban config does not seem to be a good idea because these changes may not survive VItalPBX updates.

Intrusion detection itself is working when I switch it on and is shut off when I disable it, the problem is only that I can’t shut it off permanently.

Currently running 3.1.5-3 but this happened with previous versions as well. Is this behaviour by design, or is it a bug?

If you want to disable the Intrusion detection permanently, you have to execute the command below.

systemctl disable fail2ban