SIP no re-register after internet down

Latest Vitalpbx onpremise. SIP provider. No official PJSIP Support yet.
Internet was down for about 2-3 hours.

After 5 hours realized:
Trunk said “registered” but it was not. No outbound or inbound possible.
Disable SIP-Trunk and then enable: working.

Why is it giving up? Is there a way to fix this with a setting?

And since many versions of VitalPBX the STATE is not showing anymore on PBX reports for SIP.

signal-2022-04-29-095440_001

ChanSIP (or referred as SIP in VitalPBX) is deprecated and will soon be removed from Asterisk.

So the real answer here is: Switch to PJSIP.

Unless they use a tel:uri (to which they shouldn’t). Then there’s nothing they need to support and should work without them stating that they need to support it.

I suggest you try to set up a PJSIP Trunk and report back any issues you have. (Remember that ChanSIP and PJSIP runs on different ports)

Happened again with SIP.
“sip show registry” says “No Authentication” and then it will never try again. But actually just the Internet was down for a while. VitalPBX does not show that state.

How would you convert this to PSJIP?
image

And we have this Custom Header as well:
image

Thanks!

Start by creating a PJSIP Trunk (on a lab server, unless if you can afford downtime on this server) mimicking this Trunk config.

Try incoming and outgoing calls, see what’s not working and report back with a call trace and a screenshot of the Trunk config.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.