# Registration worked but now fails from certain endpoints

**URL:** https://forums.vitalpbx.org/t/registration-worked-but-now-fails-from-certain-endpoints/4162
**Category:** VitXi WebRTC
**Created:** [June 11, 2024, 5:27pm UTC](https://forums.vitalpbx.org/t/registration-worked-but-now-fails-from-certain-endpoints/4162 "2024-06-11T17:27:17Z")
**Posts on this page:** 7
**Page:** 1

<div class="post-metadata">

### Author: ![lanvis](https://forums.vitalpbx.org/letter_avatar_proxy/v4/letter/l/5fc32e/32.png) [@lanvis](https://forums.vitalpbx.org/u/lanvis)
#### Post date: [June 11, 2024, 5:27pm UTC](https://forums.vitalpbx.org/t/registration-worked-but-now-fails-from-certain-endpoints/4162/1 "2024-06-11T17:27:17Z")

</div>

All of these endpoints worked and then 108.75.92.49 began to fail.  
Any idea why? The Websocket is up but says failed to authenticate. A successful connect to the same WebRTC account is shown from a different endpoint at botton and that works fine.

WebSocket connection from ‘108.75.91.49:50402’ for protocol ‘sip’ accepted using version ‘13’  
[2024-06-11 12:55:49] NOTICE[23773]: res\_pjsip/pjsip\_distributor.c:673 log\_failed\_request: Request ‘REGISTER’ from ‘“DrCSec” sip:404@cloudvoip.arapb.com’ failed for ‘108.75.9 1.49:50402’ (callid: sm45842qmpl9m7mdthhc5a) - Failed to authenticate  
[2024-06-11 12:55:51] NOTICE[9658]: res\_pjsip/pjsip\_distributor.c:673 log\_failed\_request: Request ‘REGISTER’ from ‘“DrCSec” sip:404@cloudvoip.arapb.com’ failed for ‘108.75.91 .49:50402’ (callid: sm45842qmpl9m7mdthhc5a) - Failed to authenticate  
[2024-06-11 12:56:46] NOTICE[9658]: res\_pjsip/pjsip\_distributor.c:673 log\_failed\_request: Request ‘REGISTER’ from ‘“DrCSec” sip:404@cloudvoip.arapb.com’ failed for ‘108.75.91.49:50402’ (callid : sm45842qmpl9m7mdthhc5a) - Failed to authenticate  
[2024-06-11 12:57:10] NOTICE[46217]: res\_pjsip/pjsip\_distributor.c:673 log\_failed\_request: Request ‘REGISTER’ from ‘“DrCSec” sip:404@cloudvoip.arapb.com’ failed for ‘108.75.91.49:50402’ (calli d: sm45842qmpl9m7mdthhc5a) - Failed to authenticate  
[2024-06-11 12:57:13] NOTICE[9658]: res\_pjsip/pjsip\_distributor.c:673 log\_failed\_request: Request ‘REGISTER’ from ‘“DrCSec” sip:404@cloudvoip.arapb.com’ failed for ‘108.75.91.49:50402’ (callid : sm45842qmpl9m7mdthhc5a) - Failed to authenticate  
== WebSocket connection from ‘69.221.112.19:60185’ for protocol ‘sip’ accepted using version ‘13’  
– Added contact ‘sip:404@69.221.112.19:60185;transport=ws;[x-ast-orig-host:5060=cloudvoip.arapb.com](http://x-ast-orig-host:5060=cloudvoip.arapb.com)’ to AOR ‘404’ with expiration of 7200 seconds  
– Contact 404/sip:404@69.221.112.19:60185;transport=ws;[x-ast-orig-host:5060=cloudvoip.arapb.com](http://x-ast-orig-host:5060=cloudvoip.arapb.com) is now Reachable. RTT: 102.368 msec

---

<div class="post-metadata">

### Author: ![maynor](https://forums.vitalpbx.org/letter_avatar_proxy/v4/letter/m/3e96dc/32.png) [@maynor](https://forums.vitalpbx.org/u/maynor)
#### Post date: [June 11, 2024, 5:29pm UTC](https://forums.vitalpbx.org/t/registration-worked-but-now-fails-from-certain-endpoints/4162/2 "2024-06-11T17:29:45Z")

</div>

Could you please share screenshots of the extension settings that are causing issues and also the WebRTC profile in use? Make sure to hide any sensitive information.

---

<div class="post-metadata">

### Author: ![lanvis](https://forums.vitalpbx.org/letter_avatar_proxy/v4/letter/l/5fc32e/32.png) [@lanvis](https://forums.vitalpbx.org/u/lanvis)
#### Post date: [June 11, 2024, 6:29pm UTC](https://forums.vitalpbx.org/t/registration-worked-but-now-fails-from-certain-endpoints/4162/3 "2024-06-11T18:29:07Z")

</div>

Not sure why this could be as I made no changes to my router/firewall. I can connect to a SIP phone and register from the same ip address location. The ipaddress is in whitelist for debian/vitalpbx. PBX is hosted at Digital Ocean.

 ![defaultwebrtcprofile](https://forums.vitalpbx.org/uploads/default/original/2X/3/32f1400d9f875a46e90b2e4b99d5d271c5969d14.jpeg)  
 ![extension404](https://forums.vitalpbx.org/uploads/default/original/2X/e/e291b0ba516c80d0a634462c140b8cb8f586df5f.jpeg)

---

<div class="post-metadata">

### Author: ![maynor](https://forums.vitalpbx.org/letter_avatar_proxy/v4/letter/m/3e96dc/32.png) [@maynor](https://forums.vitalpbx.org/u/maynor)
#### Post date: [June 11, 2024, 9:07pm UTC](https://forums.vitalpbx.org/t/registration-worked-but-now-fails-from-certain-endpoints/4162/4 "2024-06-11T21:07:23Z")

</div>

Please share the settings for the default WebRTC profile, You can find it in VitalPBX under _ **Settings \> Technology Settings \> Device Profiles** _.

---

<div class="post-metadata">

### Author: ![lanvis](https://forums.vitalpbx.org/letter_avatar_proxy/v4/letter/l/5fc32e/32.png) [@lanvis](https://forums.vitalpbx.org/u/lanvis)
#### Post date: [June 12, 2024, 12:38am UTC](https://forums.vitalpbx.org/t/registration-worked-but-now-fails-from-certain-endpoints/4162/5 "2024-06-12T00:38:49Z")

</div>

![defaultProfileWebRTC](https://forums.vitalpbx.org/uploads/default/original/2X/d/d9b8cab055ad8f76dde0d3fa2d8d486744615d4a.jpeg)

Here you go…

---

<div class="post-metadata">

### Author: ![lanvis](https://forums.vitalpbx.org/letter_avatar_proxy/v4/letter/l/5fc32e/32.png) [@lanvis](https://forums.vitalpbx.org/u/lanvis)
#### Post date: [June 12, 2024, 12:10pm UTC](https://forums.vitalpbx.org/t/registration-worked-but-now-fails-from-certain-endpoints/4162/6 "2024-06-12T12:10:07Z")

</div>

So I figured out what was going on with the WebRTC registration.

We are deploying VitalPBX as a replacement for our current asterisk v13 system and we have 3 sites. I recently added “tie” trunks from our old system to the cloud based VitalPBX (new) so that I can xfer calls from old ast13\<-\>cloudvital. Evidently the WebRTC registrations are being sent on the wrong trunk since both endpoints are our business IP. My “tie” trunk is not a registered trunk (just IP).

So my cloud Vital Configuration won’t allow a PJSIP trunk and a WebRTC extension to the same IP (our business IP). Is there any easy fix for that? I would rather change the tie trunk config if that is possible. I really have to have the tie trunk for the migration.

Thanks

---

<div class="post-metadata">

### Author: ![maynor](https://forums.vitalpbx.org/letter_avatar_proxy/v4/letter/m/3e96dc/32.png) [@maynor](https://forums.vitalpbx.org/u/maynor)
#### Post date: [August 28, 2024, 8:23pm UTC](https://forums.vitalpbx.org/t/registration-worked-but-now-fails-from-certain-endpoints/4162/7 "2024-08-28T20:23:31Z")

</div>

I see that your case requires a bit more analysis. Please open a ticket at [https://helpdesk.vitalpbx.com/](https://helpdesk.vitalpbx.com/) so that you can receive assistance
