Queue agent announcement 'None' not stopping latest set announcement

I’m on:
VitalPBX 3.1.1-1
Asterisk 18.5.1-1

The issue:
PBX > Call Center > Queues > General > Agent Announcement

If an announcement was already set, changing to ‘None’ let’s still play the last set announcement.

As a workaround ‘core restart now’ seems to work.

But I don’t think this is a good procedure if there are tenants on the system.

I am not sure if this is a VitalPBX or an Asterisk problem.

Let me know.


1 Like

Hello @pbxprovider

This seems to be an asterisk issue,
If you’re looking for a workaround without having to restart asterisk, you can manually edit the queue conf file located in /etc/asterisk/vitalpbx/queues__50-1-main.conf or in a multi tenant it will be /etc/asterisk/vitalpbx/queues__50-{tenant_number}-main.conf and add back the “announce=” option without specifying a file to play (see screenshot below), then do a core reload asterisk -x"core reload"
Then if you want, you can update and reload from the GUI again to remove the announce.


Wouldn’t that be a task for VitalPBX?
Because if VitalPBX would set it accordingly, there would be no need to edit the file manually, right?

I don’t imagine this is amusing in a multi-tenant environment, having to set this ‘by hand’ for each tenant when they have changed it over.

So could we agree that this should be fixed by VitalPBX?


Yes @pbxprovider you are right about that.
What i meant with saying it’s an asterisk issue was, that asterisk should know to remove the announcement if it doesn’t exist in the conf file, and currently it’s not, even if you reload the queue module.
But you’re definitely right that vital should do it instead of you having to edit the files manually.

1 Like

We will fix this issue in the next VitalPBX Release.

The fix for this issue comes included on VitalPBX 3.1.1 R2.

1 Like