# Lets Encrypt Renew Certificate error

**URL:** https://forums.vitalpbx.org/t/lets-encrypt-renew-certificate-error/4962
**Category:** VitalPBX
**Created:** [February 4, 2025, 8:51pm UTC](https://forums.vitalpbx.org/t/lets-encrypt-renew-certificate-error/4962 "2025-02-04T20:51:20Z")
**Posts on this page:** 6
**Page:** 1

<div class="post-metadata">

### Author: ![lbochini](https://forums.vitalpbx.org/letter_avatar_proxy/v4/letter/l/e8c25b/32.png) [@lbochini](https://forums.vitalpbx.org/u/lbochini)
#### Post date: [February 4, 2025, 8:51pm UTC](https://forums.vitalpbx.org/t/lets-encrypt-renew-certificate-error/4962/1 "2025-02-04T20:51:20Z")

</div>

I tried to renew an Lets encrypt certificate, and i got the following error:

 ![image](https://forums.vitalpbx.org/uploads/default/original/2X/5/56916668a484c419094c2ad582e15e813d667cc4.png)

In the In the /var/log/vitalpbx/letsencrypt.log file i have this:

[2025-02-04 16:24:29.480129] [debug] GET response received  
request: ‘GET [https://acme-v02.api.letsencrypt.org/directory](https://acme-v02.api.letsencrypt.org/directory)’  
header: 'HTTP/2 200  
server: nginx  
date: Tue, 04 Feb 2025 19:24:29 GMT  
content-type: application/json  
content-length: 828  
cache-control: public, max-age=0, no-cache  
x-frame-options: DENY  
strict-transport-security: max-age=604800

```
'
status: 200
body: array(
    'keyChange' => 'https://acme-v02.api.letsencrypt.org/acme/key-change',
    'meta' => array(
        'caaIdentities' => array(
            0 => 'letsencrypt.org',
        ),
        'profiles' => array(
            'classic' => 'The same profile you're accustomed to',
        ),
        'termsOfService' => 'https://letsencrypt.org/documents/LE-SA-v1.4-April-3-2024.pdf',
        'website' => 'https://letsencrypt.org',
    ),
    'newAccount' => 'https://acme-v02.api.letsencrypt.org/acme/new-acct',
    'newNonce' => 'https://acme-v02.api.letsencrypt.org/acme/new-nonce',
    'newOrder' => 'https://acme-v02.api.letsencrypt.org/acme/new-order',
    'renewalInfo' => 'https://acme-v02.api.letsencrypt.org/draft-ietf-acme-ari-03/renewalInfo',
    'revokeCert' => 'https://acme-v02.api.letsencrypt.org/acme/revoke-cert',
    'w1295c5WixY' => 'https://community.letsencrypt.org/t/adding-random-entries-to-the-directory/33417',
)

```

[2025-02-04 16:24:29.996212] [debug] HEAD response received  
request: ‘HEAD [https://acme-v02.api.letsencrypt.org/acme/new-nonce](https://acme-v02.api.letsencrypt.org/acme/new-nonce)’  
header: 'HTTP/2 200  
server: nginx  
date: Tue, 04 Feb 2025 19:24:29 GMT  
cache-control: public, max-age=0, no-cache  
link: [https://acme-v02.api.letsencrypt.org/directory](https://acme-v02.api.letsencrypt.org/directory);rel=“index”  
replay-nonce: aTttXYyySEOY2HO8LMVKDNVupf7ssmJ-L-MsqlmY9ELUJ9R\_umw  
x-frame-options: DENY  
strict-transport-security: max-age=604800

```
'
status: 200
body: ''

```

[2025-02-04 16:24:29.999108] [info] No account found, attempting to create account.  
[2025-02-04 16:24:32.577275] [debug] POST response received  
request: ‘POST [https://acme-v02.api.letsencrypt.org/acme/new-acct](https://acme-v02.api.letsencrypt.org/acme/new-acct)’  
header: 'HTTP/2 201  
server: nginx  
date: Tue, 04 Feb 2025 19:24:32 GMT  
content-type: application/json  
content-length: 875  
boulder-requester: 2209643605  
cache-control: public, max-age=0, no-cache  
link: [https://acme-v02.api.letsencrypt.org/directory](https://acme-v02.api.letsencrypt.org/directory);rel=“index”  
link: [https://letsencrypt.org/documents/LE-SA-v1.4-April-3-2024.pdf](https://letsencrypt.org/documents/LE-SA-v1.4-April-3-2024.pdf);rel=“terms-of-service”  
location: [https://acme-v02.api.letsencrypt.org/acme/acct/2209643605](https://acme-v02.api.letsencrypt.org/acme/acct/2209643605)  
replay-nonce: UvlUZ57Po5hOAcTS7PNJNokAvqv56eLcgYqRBASj7xAtupmeejM  
x-frame-options: DENY  
strict-transport-security: max-age=604800

```
'
status: 201
body: array(
    'key' => array(
        'kty' => 'RSA',
        'n' => '1-uHo58WFQOtmsMuJ5zEKJ4V3WVZrUfuydgRpOytxXod_X851sbifd9sk5KEmIeNqpqBZNF3Y7SRzQPoFYzcFASR53jfTfEQ-Y8l-O4q06u0uOl9LyXb1Yp8XN_ruwLIlWw6dKbGmon7GZxb7UQD9LoSQZaTlh_ZYO2YjXB_FIgvXsGSLIz39YX_QuNuiL97soVtny-2y40uwHD-kIWa8TnbFIpVQGVyVCvmxUOrG5kzFV_ELB3sCtQi3Pc0DAns4E6tGFLiexryWT1F0TLoGq-7_bYX58XrObpBCRRRlEKZpp-aTNT8D8AcH9BxwoeSWgWONcVfvC9NEld-cEMEWRVPaMJjCfl0rhZzk2GAE3Xy33BKlR5jMWuPIHnH6aqaZZ7huCLF_ZpaUFmh9AE30eKKNin5dUYd65WOk351hD3x0e2U6FkxiuWC5lSKqbWshahhJuvZUZHayMo2Jklrznqqj0zcQZdtB_DVJdO_iBuBkWnUGBIQQozVqroH4UwqvwgA-lAN3NmABLooyMQqZLOTPASvUZgAj5je_YLLWbnwhYkQpwn4wWvwGOkVYDalQ6e9ebVeVO-62ujFjBmtBZzIzgh7vwVqxUg78H6UdH8eW-ELV0WNESyhf-h0wMlhJM-HeLRWnV5S65B_iyMSpg1vIsovd4Ivbz9Qrrijwl0',
        'e' => 'AQAB',
    ),
    'contact' => array(
        0 => 'mailto:suporte@manzanos.com.br',
    ),
    'createdAt' => '2025-02-04T19:24:32.477167089Z',
    'status' => 'valid',
)

```

[2025-02-04 16:24:33.141096] [debug] POST response received  
request: ‘POST [https://acme-v02.api.letsencrypt.org/acme/acct/2209643605](https://acme-v02.api.letsencrypt.org/acme/acct/2209643605)’  
header: 'HTTP/2 200  
server: nginx  
date: Tue, 04 Feb 2025 19:24:33 GMT  
content-type: application/json  
content-length: 808  
boulder-requester: 2209643605  
cache-control: public, max-age=0, no-cache  
link: [https://acme-v02.api.letsencrypt.org/directory](https://acme-v02.api.letsencrypt.org/directory);rel=“index”  
link: [https://letsencrypt.org/documents/LE-SA-v1.4-April-3-2024.pdf](https://letsencrypt.org/documents/LE-SA-v1.4-April-3-2024.pdf);rel=“terms-of-service”  
replay-nonce: TUC11O6XLV7hCblDT8qi6RRusXJfoQBC4M\_H3qmTJPSZTgJtoao  
x-frame-options: DENY  
strict-transport-security: max-age=604800

```
'
status: 200
body: array(
    'key' => array(
        'kty' => 'RSA',
        'n' => '1-uHo58WFQOtmsMuJ5zEKJ4V3WVZrUfuydgRpOytxXod_X851sbifd9sk5KEmIeNqpqBZNF3Y7SRzQPoFYzcFASR53jfTfEQ-Y8l-O4q06u0uOl9LyXb1Yp8XN_ruwLIlWw6dKbGmon7GZxb7UQD9LoSQZaTlh_ZYO2YjXB_FIgvXsGSLIz39YX_QuNuiL97soVtny-2y40uwHD-kIWa8TnbFIpVQGVyVCvmxUOrG5kzFV_ELB3sCtQi3Pc0DAns4E6tGFLiexryWT1F0TLoGq-7_bYX58XrObpBCRRRlEKZpp-aTNT8D8AcH9BxwoeSWgWONcVfvC9NEld-cEMEWRVPaMJjCfl0rhZzk2GAE3Xy33BKlR5jMWuPIHnH6aqaZZ7huCLF_ZpaUFmh9AE30eKKNin5dUYd65WOk351hD3x0e2U6FkxiuWC5lSKqbWshahhJuvZUZHayMo2Jklrznqqj0zcQZdtB_DVJdO_iBuBkWnUGBIQQozVqroH4UwqvwgA-lAN3NmABLooyMQqZLOTPASvUZgAj5je_YLLWbnwhYkQpwn4wWvwGOkVYDalQ6e9ebVeVO-62ujFjBmtBZzIzgh7vwVqxUg78H6UdH8eW-ELV0WNESyhf-h0wMlhJM-HeLRWnV5S65B_iyMSpg1vIsovd4Ivbz9Qrrijwl0',
        'e' => 'AQAB',
    ),
    'createdAt' => '2025-02-04T19:24:32Z',
    'status' => 'valid',

```

If i try to renew the certificate again, the error changes:

 ![image](https://forums.vitalpbx.org/uploads/default/original/2X/d/dee149184fbaa000cc6134c9b397ac99b4635192.png)

In the same letsencrypt.log file i have this now:

[2025-02-04 16:50:13.606534] [debug] GET response received  
request: ‘GET [https://acme-v02.api.letsencrypt.org/directory](https://acme-v02.api.letsencrypt.org/directory)’  
header: 'HTTP/2 200  
server: nginx  
date: Tue, 04 Feb 2025 19:50:13 GMT  
content-type: application/json  
content-length: 828  
cache-control: public, max-age=0, no-cache  
x-frame-options: DENY  
strict-transport-security: max-age=604800

```
'
status: 200
body: array(
    '_AT4INIA8QY' => 'https://community.letsencrypt.org/t/adding-random-entries-to-the-directory/33417',
    'keyChange' => 'https://acme-v02.api.letsencrypt.org/acme/key-change',
    'meta' => array(
        'caaIdentities' => array(
            0 => 'letsencrypt.org',
        ),
        'profiles' => array(
            'classic' => 'The same profile you're accustomed to',
        ),
        'termsOfService' => 'https://letsencrypt.org/documents/LE-SA-v1.4-April-3-2024.pdf',
        'website' => 'https://letsencrypt.org',
    ),
    'newAccount' => 'https://acme-v02.api.letsencrypt.org/acme/new-acct',
    'newNonce' => 'https://acme-v02.api.letsencrypt.org/acme/new-nonce',
    'newOrder' => 'https://acme-v02.api.letsencrypt.org/acme/new-order',
    'renewalInfo' => 'https://acme-v02.api.letsencrypt.org/draft-ietf-acme-ari-03/renewalInfo',
    'revokeCert' => 'https://acme-v02.api.letsencrypt.org/acme/revoke-cert',
)

```

[2025-02-04 16:50:14.082468] [debug] HEAD response received  
request: ‘HEAD [https://acme-v02.api.letsencrypt.org/acme/new-nonce](https://acme-v02.api.letsencrypt.org/acme/new-nonce)’  
header: 'HTTP/2 200  
server: nginx  
date: Tue, 04 Feb 2025 19:50:14 GMT  
cache-control: public, max-age=0, no-cache  
link: [https://acme-v02.api.letsencrypt.org/directory](https://acme-v02.api.letsencrypt.org/directory);rel=“index”  
replay-nonce: TUC11O6Xq8HAtYad4csY9rMvSItvUuD7\_PILBWfpzYzwiSesGVY  
x-frame-options: DENY  
strict-transport-security: max-age=604800

```
'
status: 200
body: ''

```

[2025-02-04 16:50:14.085544] [info] No account found, attempting to create account.  
[2025-02-04 16:50:14.977061] [debug] POST response received  
request: ‘POST [https://acme-v02.api.letsencrypt.org/acme/new-acct](https://acme-v02.api.letsencrypt.org/acme/new-acct)’  
header: 'HTTP/2 429  
server: nginx  
date: Tue, 04 Feb 2025 19:50:14 GMT  
content-type: application/problem+json  
content-length: 275  
cache-control: public, max-age=0, no-cache  
link: [https://acme-v02.api.letsencrypt.org/directory](https://acme-v02.api.letsencrypt.org/directory);rel=“index”  
link: [https://letsencrypt.org/docs/rate-limits](https://letsencrypt.org/docs/rate-limits);rel=“help”  
replay-nonce: UvlUZ57PunSuF7tGXiq1jrh93076TElk3ptNAqBbOZ9daApcAjg  
retry-after: 502

```
'
status: 429
body: array(
    'type' => 'urn:ietf:params:acme:error:rateLimited',
    'detail' => 'too many new registrations (10) from this IP address in the last 3h0m0s, retry after 2025-02-04 19:58:37 UTC: see https://letsencrypt.org/docs/rate-limits/#new-registrations-per-ip-address',
    'status' => 429,
)

```

I assume this was an error with the account, since the log says “no account found, attempting to create account”. So i deleted the certificate and tried to create a new one, but now i dont have my certificate anymore, and still receiving the same error. Any ideas?

Btw, the [vitalpbx.com](http://vitalpbx.com) and [helpdesk.vitalpbx.com](http://helpdesk.vitalpbx.com) is down for me, so i cant create a ticket for this issue.

---

<div class="post-metadata">

### Author: ![PitzKey](https://forums.vitalpbx.org/user_avatar/forums.vitalpbx.org/pitzkey/32/420_2.png) [@PitzKey](https://forums.vitalpbx.org/u/PitzKey)
#### Post date: [February 4, 2025, 8:52pm UTC](https://forums.vitalpbx.org/t/lets-encrypt-renew-certificate-error/4962/2 "2025-02-04T20:52:19Z")

</div>

What version of VitalPBX?

---

<div class="post-metadata">

### Author: ![lbochini](https://forums.vitalpbx.org/letter_avatar_proxy/v4/letter/l/e8c25b/32.png) [@lbochini](https://forums.vitalpbx.org/u/lbochini)
#### Post date: [February 5, 2025, 12:12pm UTC](https://forums.vitalpbx.org/t/lets-encrypt-renew-certificate-error/4962/3 "2025-02-05T12:12:18Z")

</div>

System Information  
Distro Debian GNU/Linux 11 (bullseye)  
Kernel 5.10.0-32-cloud-amd64  
PBX Engine 18.23.1  
VitalPBX 4.1.0-7  
PHP Version 8.1.11

---

<div class="post-metadata">

### Author: ![PitzKey](https://forums.vitalpbx.org/user_avatar/forums.vitalpbx.org/pitzkey/32/420_2.png) [@PitzKey](https://forums.vitalpbx.org/u/PitzKey)
#### Post date: [February 5, 2025, 12:45pm UTC](https://forums.vitalpbx.org/t/lets-encrypt-renew-certificate-error/4962/4 "2025-02-05T12:45:49Z")

</div>

Well, if you did a quick search on the forums you will see that LetsEncrypt issues has been fixed in recent updates.

Please update your PBX to the latest version and report back if you still have the exact same issue.

---

<div class="post-metadata">

### Author: ![lbochini](https://forums.vitalpbx.org/letter_avatar_proxy/v4/letter/l/e8c25b/32.png) [@lbochini](https://forums.vitalpbx.org/u/lbochini)
#### Post date: [February 5, 2025, 1:31pm UTC](https://forums.vitalpbx.org/t/lets-encrypt-renew-certificate-error/4962/5 "2025-02-05T13:31:46Z")

</div>

Thanks! After updating the server, the issue was fixed.

---

<div class="post-metadata">

### Author: ![system](https://forums.vitalpbx.org/uploads/default/original/1X/672b458a1d454755270c2c16adc5316b641c3c6a.png) [@system](https://forums.vitalpbx.org/u/system)
#### Post date: [March 7, 2025, 1:32pm UTC](https://forums.vitalpbx.org/t/lets-encrypt-renew-certificate-error/4962/6 "2025-03-07T13:32:11Z")

</div>

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.
