Connection Could not be established

Hi. I configured VitXi WebRTC on our server. All is working, but on every client the sttartup time is taking long (abour 30 seconds). When loading is completed client is active and registered (both on windows app and android systems), but popup is always visible. Tested with Lets’ encrypt certificate and with our UCC SAN certificate.

Immagine 2022-11-13 094406

Screenshot_20221113-091440

1 Like

Hi Sir,

What version of VitalPBX do you have, is it the debian version?

Regards,

Hi. No, it’s the CentOS Linux release 7.9.2009 (Core), VitalPBX 3.2.3-6. I realized just now that a debian version exists. I just clicked on the download ISO from the homepage… Maybe I can try to install VitalPBX as explained here: https://vitalpbx.com/blog/install-vitalpbx-4-in-debian/ ?
Thank you.

Is port 8089 unblocked? Where’s the server hosted? What’s your infrastructure?

1 Like

Hi Miguel, sorry for the delay. I think I didn’t understand something. VitXi is working well on Android Mobile App and on Windows App. The problem shown above raise when it’s accessed through chrome extension.
The Chrome log keep on showing this:
Screenshot 2022-11-17 083921

How the WebRtc is supposed to be used? With the android/Windows app or on webrtc url?
Thank you.

1 Like

Hi Sir,

Please restart the vitxi service and check the status with systemctl restart vitxi && systemctl status vitxi

Status is running. But I discovered the WebSocket service is on port 6001. tried to add to firewall in VitalPbx and router, but still the same error.
Screenshot 2022-11-17 173900

Please leave the WebSocket as it is here 8089 and try again and report.

Tried to change back to 8089 (opening ports), but still the same error. Sorry, forgot to answer: I have all custom ports, but didn’t know it could be a problem. Maybe a fresh install with all default ports?
Screenshot 2022-11-17 182415

Just an idea. Test it.