# Broken Update to 4.5.1-2

**URL:** https://forums.vitalpbx.org/t/broken-update-to-4-5-1-2/5612
**Category:** Reporting an Issue
**Created:** [July 31, 2025, 11:28am UTC](https://forums.vitalpbx.org/t/broken-update-to-4-5-1-2/5612 "2025-07-31T11:28:25Z")
**Posts on this page:** 20
**Page:** 1

<div class="post-metadata">

### Author: ![PitzKey](https://forums.vitalpbx.org/user_avatar/forums.vitalpbx.org/pitzkey/32/420_2.png) [@PitzKey](https://forums.vitalpbx.org/u/PitzKey)
#### Post date: [July 31, 2025, 11:28am UTC](https://forums.vitalpbx.org/t/broken-update-to-4-5-1-2/5612/1 "2025-07-31T11:28:25Z")

</div>

Hello,

We updated today to the latest version.

At some point it started failing.

Part 1 of the logs, also pastebin [Logs Part1 - Pastebin.com](https://pastebin.com/FpmnE3jJ)

```bash
Setting up nginx (1.22.1-9+deb12u2) ...
Job for nginx.service failed because the control process exited with error code.
See "systemctl status nginx.service" and "journalctl -xeu nginx.service" for details.
invoke-rc.d: initscript nginx, action "start" failed.
× nginx.service - A high performance web server and a reverse proxy server
     Loaded: loaded (/lib/systemd/system/nginx.service; enabled; preset: enabled)
     Active: failed (Result: exit-code) since Thu 2025-07-31 06:11:23 EDT; 31ms ago
   Duration: 3month 1w 3d 12h 36min 7.153s
       Docs: man:nginx(8)
    Process: 637413 ExecStartPre=/usr/sbin/nginx -t -q -g daemon on; master_process on; (code=exited, status=1/FAILURE)
        CPU: 63ms

Jul 31 06:11:23 core1 systemd[1]: Starting nginx.service - A high performance web server and a reverse proxy server...
Jul 31 06:11:23 core1 nginx[637413]: 2025/07/31 06:11:23 [emerg] 637413#637413: duplicate location "/events-logs/v1" in /etc/nginx/pbx-addons/vitalpbx-logs.conf.dpkg-new:1
Jul 31 06:11:23 core1 nginx[637413]: nginx: configuration file /etc/nginx/nginx.conf test failed
Jul 31 06:11:23 core1 systemd[1]: nginx.service: Control process exited, code=exited, status=1/FAILURE
Jul 31 06:11:23 core1 systemd[1]: nginx.service: Failed with result 'exit-code'.
Jul 31 06:11:23 core1 systemd[1]: Failed to start nginx.service - A high performance web server and a reverse proxy server.
dpkg: error processing package nginx (--configure):
 installed nginx package post-installation script subprocess returned error exit status 1
dpkg: dependency problems prevent configuration of sonata-switchboard:
 sonata-switchboard depends on nginx; however:
  Package nginx is not configured yet.

dpkg: error processing package sonata-switchboard (--configure):
 dependency problems - leaving unconfigured
Setting up libpython3.11-stdlib:amd64 (3.11.2-6+deb12u6) ...
dpkg: dependency problems prevent configuration of sonata-recordings:
 sonata-recordings depends on nginx; however:
  Package nginx is not configured yet.

dpkg: error processing package sonata-recordings (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of vitalpbx:
 vitalpbx depends on nginx; however:
  Package nginx is not configured yet.

dpkg: error processing package vitalpbx (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of vitalpbx-sms:
 vitalpbx-sms depends on vitalpbx (>= 4.5.0-1); however:
  Package vitalpbx is not configured yet.

dpkg: error processing package vitalpbx-sms (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of vitalpbx-voice-hub:
 vitalpbx-voice-hub depends on vitalpbx (>= 4.5.0-1); however:
  Package vitalpbx is not configured yet.

dpkg: error processing package vitalpbx-voice-hub (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of provisioning-core:
 provisioning-core depends on nginx; however:
  Package nginx is not configured yet.

dpkg: error processing package provisioning-core (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of vitalpbx-ai-assistants:
 vitalpbx-ai-assistants depends on vitalpbx (>= 4.5.0-1); however:
  Package vitalpbx is not configured yet.
 vitalpbx-ai-assistants depends on vitalpbx-voice-hub (>= 4.5.0-2); however:
  Package vitalpbx-voice-hub is not configured yet.

dpkg: error processing package vitalpbx-ai-assistants (--configure):
 dependency problems - leaving unconfigured
Setting up ca-certificates (20230311+deb12u1) ...
Updating certificates in /etc/ssl/certs...
rehash: warning: skipping ca-certificates.crt,it does not contain exactly one certificate or CRL
rehash: warning: skipping dhparam.pem,it does not contain exactly one certificate or CRL
2 added, 0 removed; done.
dpkg: dependency problems prevent configuration of sonata-stats:
 sonata-stats depends on nginx; however:
  Package nginx is not configured yet.

dpkg: error processing package sonata-stats (--configure):
 dependency problems - leaving unconfigured
Setting up libmagickcore-6.q16-6:amd64 (8:6.9.11.60+dfsg-1.6+deb12u3) ...
Setting up php8.2-xml (8.2.29-1~deb12u1) ...
Setting up redis-tools (5:7.0.15-1~deb12u4) ...
Setting up libgcc-12-dev:amd64 (12.2.0-14+deb12u1) ...
Setting up libgssapi-krb5-2:amd64 (1.20.1-2+deb12u3) ...
dpkg: dependency problems prevent configuration of vitalpbx-connect:
 vitalpbx-connect depends on vitalpbx (>= 4.5.0-1); however:
  Package vitalpbx is not configured yet.

dpkg: error processing package vitalpbx-connect (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of vitalpbx-phones-provisioning:
 vitalpbx-phones-provisioning depends on vitalpbx; however:
  Package vitalpbx is not configured yet.
 vitalpbx-phones-provisioning depends on provisioning-core (>= 4.5.0-7); however:
  Package provisioning-core is not configured yet.

dpkg: error processing package vitalpbx-phones-provisioning (--configure):
 dependency problems - leaving unconfigured
Setting up linux-image-6.1.0-37-amd64 (6.1.140-1) ...
I: /vmlinuz.old is now a symlink to boot/vmlinuz-6.1.0-33-amd64
I: /initrd.img.old is now a symlink to boot/initrd.img-6.1.0-33-amd64
I: /vmlinuz is now a symlink to boot/vmlinuz-6.1.0-37-amd64
I: /initrd.img is now a symlink to boot/initrd.img-6.1.0-37-amd64
/etc/kernel/postinst.d/initramfs-tools:
update-initramfs: Generating /boot/initrd.img-6.1.0-37-amd64
/etc/kernel/postinst.d/zz-update-grub:
Generating grub configuration file ...
Found linux image: /boot/vmlinuz-6.1.0-37-amd64
Found initrd image: /boot/initrd.img-6.1.0-37-amd64
Found linux image: /boot/vmlinuz-6.1.0-33-amd64
Found initrd image: /boot/initrd.img-6.1.0-33-amd64
Found linux image: /boot/vmlinuz-6.1.0-32-amd64
Found initrd image: /boot/initrd.img-6.1.0-32-amd64
Found linux image: /boot/vmlinuz-5.10.0-33-amd64
Found initrd image: /boot/initrd.img-5.10.0-33-amd64
Warning: os-prober will not be executed to detect other bootable partitions.
Systems on them will not be added to the GRUB boot configuration.
Check GRUB_DISABLE_OS_PROBER documentation entry.
Adding boot menu entry for UEFI Firmware Settings ...
done
Setting up libgdk-pixbuf2.0-bin (2.42.10+dfsg-1+deb12u2) ...
Setting up libmagickwand-6.q16-6:amd64 (8:6.9.11.60+dfsg-1.6+deb12u3) ...
dpkg: dependency problems prevent configuration of logger-core:
 logger-core depends on nginx; however:
  Package nginx is not configured yet.

dpkg: error processing package logger-core (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of sonata-billing:
 sonata-billing depends on nginx; however:
  Package nginx is not configured yet.

dpkg: error processing package sonata-billing (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of vitalpbx-queues-callback:
 vitalpbx-queues-callback depends on vitalpbx; however:
  Package vitalpbx is not configured yet.

dpkg: error processing package vitalpbx-queues-callback (--configure):
 dependency problems - leaving unconfigured
Setting up php8.2-cli (8.2.29-1~deb12u1) ...
dpkg: dependency problems prevent configuration of vitalpbx-phone-books:
 vitalpbx-phone-books depends on vitalpbx; however:
  Package vitalpbx is not configured yet.

dpkg: error processing package vitalpbx-phone-books (--configure):
 dependency problems - leaving unconfigured
Setting up python3.11 (3.11.2-6+deb12u6) ...
dpkg: dependency problems prevent configuration of vitxi:
 vitxi depends on nginx; however:
  Package nginx is not configured yet.

dpkg: error processing package vitxi (--configure):
 dependency problems - leaving unconfigured
Setting up libpython3.11:amd64 (3.11.2-6+deb12u6) ...
Setting up libstdc++-12-dev:amd64 (12.2.0-14+deb12u1) ...
Setting up openssh-client (1:9.2p1-2+deb12u7) ...
dpkg: dependency problems prevent configuration of vitalpbx-multi-tenant:
 vitalpbx-multi-tenant depends on vitalpbx; however:
  Package vitalpbx is not configured yet.

dpkg: error processing package vitalpbx-multi-tenant (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of vitalpbx-virtual-faxes:
 vitalpbx-virtual-faxes depends on vitalpbx; however:
  Package vitalpbx is not configured yet.
 vitalpbx-virtual-faxes depends on vitalpbx-multi-tenant (>= 4.5.0-3); however:
  Package vitalpbx-multi-tenant is not configured yet.

dpkg: error processing package vitalpbx-virtual-faxes (--configure):
 dependency problems - leaving unconfigured
Setting up libpq5:amd64 (15.13-0+deb12u1) ...
Setting up asterisk-pbx-modules (20.15.0-1) ...
Setting up linux-image-amd64 (6.1.140-1) ...
Setting up redis-server (5:7.0.15-1~deb12u4) ...
Setting up php8.2-phpdbg (8.2.29-1~deb12u1) ...
Setting up php8.2-fpm (8.2.29-1~deb12u1) ...
Setting up python3.11-venv (3.11.2-6+deb12u6) ...
Setting up gcc-12 (12.2.0-14+deb12u1) ...
Setting up libpython3.11-dev:amd64 (3.11.2-6+deb12u6) ...
Setting up asterisk-pbx (20.15.0-1) ...
Setting up g++-12 (12.2.0-14+deb12u1) ...
Setting up openssh-sftp-server (1:9.2p1-2+deb12u7) ...
Setting up openssh-server (1:9.2p1-2+deb12u7) ...
rescue-ssh.target is a disabled or a static unit not running, not starting it.
ssh.socket is a disabled or a static unit not running, not starting it.
Setting up python3.11-dev (3.11.2-6+deb12u6) ...
Processing triggers for systemd (252.38-1~deb12u1) ...
Processing triggers for man-db (2.11.2-2) ...
Processing triggers for mariadb-server (1:10.11.11-0+deb12u1) ...
Processing triggers for dbus (1.14.10-1~deb12u1) ...
Processing triggers for debianutils (5.7-0.5~deb12u1) ...
Processing triggers for mailcap (3.70+nmu1) ...
Processing triggers for libc-bin (2.36-9+deb12u10) ...
Processing triggers for initramfs-tools (0.142+deb12u3) ...
update-initramfs: Generating /boot/initrd.img-6.1.0-37-amd64
Processing triggers for ca-certificates (20230311+deb12u1) ...
Updating certificates in /etc/ssl/certs...
0 added, 0 removed; done.
Running hooks in /etc/ca-certificates/update.d...
done.
Processing triggers for php8.2-cli (8.2.29-1~deb12u1) ...
Processing triggers for php8.2-phpdbg (8.2.29-1~deb12u1) ...
Processing triggers for php8.2-fpm (8.2.29-1~deb12u1) ...
Errors were encountered while processing:
 nginx
 sonata-switchboard
 sonata-recordings
 vitalpbx
 vitalpbx-sms
 vitalpbx-voice-hub
 provisioning-core
 vitalpbx-ai-assistants
 sonata-stats
 vitalpbx-connect
 vitalpbx-phones-provisioning
 logger-core
 sonata-billing
 vitalpbx-queues-callback
 vitalpbx-phone-books
 vitxi
 vitalpbx-multi-tenant
 vitalpbx-virtual-faxes
E: Sub-process /usr/bin/dpkg returned an error code (1)

```

As you can see it complained about duplicates of `"/events-logs/v1"`, which was obvious why, since all the `.dpkg-new` files still exsisted, I removed them all and ran `dpkg --configure -a`

Here is part of after running `dpkg --configure -a` also on pastebin [Logs Part2 - Pastebin.com](https://pastebin.com/nmSsFiSK)

```bash
root@core1:~# dpkg --configure -a
Setting up nginx (1.22.1-9+deb12u2) ...
Setting up sonata-switchboard (4.5.0-4) ...
Setting up sonata-recordings (4.5.0-4) ...
Setting up provisioning-core (4.5.0-7) ...

   INFO Application cache cleared successfully.  

   INFO Clearing cached bootstrap files.  

  events .................................................................................................................................. 3ms DONE
  views .................................................................................................................................. 21ms DONE
  cache .................................................................................................................................. 13ms DONE
  route ................................................................................................................................... 2ms DONE
  config .................................................................................................................................. 2ms DONE
  compiled ................................................................................................................................ 3ms DONE

   INFO Route cache cleared successfully.  

   INFO Caching the framework bootstrap files.  

  config ................................................................................................................................. 31ms DONE
  routes ................................................................................................................................. 25ms DONE

Setting up sonata-stats (4.0.5-4) ...

   INFO Application cache cleared successfully.  

   INFO Clearing cached bootstrap files.  

  events .................................................................................................................................. 4ms DONE
  views .................................................................................................................................. 18ms DONE
  cache ................................................................................................................................... 7ms DONE
  route ................................................................................................................................... 3ms DONE
  config .................................................................................................................................. 1ms DONE
  compiled ................................................................................................................................ 1ms DONE

   INFO Caching the framework bootstrap files.  

  config ................................................................................................................................. 50ms DONE
  routes ................................................................................................................................. 42ms DONE

   INFO Routes cached successfully.  

   INFO Configuration cached successfully.  

   INFO Nothing to migrate.  

Setting up logger-core (4.5.0-3) ...

   INFO Application cache cleared successfully.  

   INFO Clearing cached bootstrap files.  

  cache ................................................................................................................................ 5.80ms DONE
  compiled ............................................................................................................................. 2.10ms DONE
  config ............................................................................................................................... 1.24ms DONE
  events ............................................................................................................................... 1.33ms DONE
  routes ............................................................................................................................... 1.23ms DONE
  views ............................................................................................................................... 31.58ms DONE

   INFO Route cache cleared successfully.  

   INFO Caching framework bootstrap, configuration, and metadata.  

  config .............................................................................................................................. 38.49ms DONE
  events ............................................................................................................................... 3.25ms DONE
  routes .............................................................................................................................. 29.13ms DONE
  views .............................................................................................................................. 107.11ms DONE

Setting up sonata-billing (4.5.0-2) ...
Setting up vitxi (4.5.0-6) ...
Updating 'vitxi' wrapper script...
Starting the .env update process...
Found existing .env file: /usr/share/vitxi/backend/.env
Updating variable DB_CONNECTION to new value mariadb
Updating variable REVERB_APP_ID to new value vitxi_app
Updating variable REVERB_APP_KEY to new value vitxi4561aq
Updating variable REVERB_APP_SECRET to new value va9UMJwqYhs9aKW53FH+asd
Removed empty lines from .env file
Updated .env file has been saved
Restored original permissions, owner, and group to .env file
Temporary file cleaned up
Checking JWT_SECRET and DB_PASSWORD in /usr/share/vitxi/backend/.env...
JWT_SECRET is already set.
DB_PASSWORD is already set.

   INFO Application cache cleared successfully.  

   INFO Caching framework bootstrap, configuration, and metadata.  

  config .............................................................................................................................. 59.63ms DONE
  events ............................................................................................................................... 3.30ms DONE
  routes .............................................................................................................................. 48.38ms DONE
  views ............................................................................................................................... 79.57ms DONE

   INFO Nothing to migrate.  

   INFO Routes cached successfully.  

   INFO Configuration cached successfully.  

   INFO Caching framework bootstrap, configuration, and metadata.  

  config .............................................................................................................................. 49.58ms DONE
  events ............................................................................................................................... 2.24ms DONE
  routes .............................................................................................................................. 44.18ms DONE
  views ............................................................................................................................... 60.60ms DONE

Cron entry already exists in /etc/cron.d/vitxi
Setting up vitalpbx (4.5.1-2) ...
Importing 20250409.1.backup_groups_uuid.sql...
Executing 20250409.2.add_uuid.php...
Importing 20250515.1.backup_groups_uuid_update.sql...
Configuring Tenant: MAIN PBX...
PHP Fatal error: Uncaught Exception: SQLSTATE[42S02]: Base table or view not found: 1146 Table 'ombutel.ombu_tenant_dids' doesn't exist With Query: select `did` from ombu_tenant_dids where `tenant_id` = ? in /usr/share/vitalpbx/www/includes/db.php:0
Stack trace:
#0 /usr/share/vitalpbx/www/includes/db.php(0): vitalpbx\db->__construct()
#1 /usr/share/vitalpbx/www/modules/tenants/DIDNumber.php(0): vitalpbx\db::query()
#2 /usr/share/vitalpbx/www/includes/tenant.php(0): modules\tenants\DIDNumber::getAllByTenant()
#3 /usr/share/vitalpbx/www/modules/tenants/Asterisk/DialPlan.php(0): vitalpbx\tenant->getInboundDIDs()
#4 [internal function]: modules\tenants\Asterisk\DialPlan::modules\tenants\Asterisk\{closure}()
#5 /usr/share/vitalpbx/www/modules/tenants/Asterisk/DialPlan.php(0): array_map()
#6 /usr/share/vitalpbx/www/modules/inbound_route/Asterisk/DialPlan.php(0): modules\tenants\Asterisk\DialPlan::buildIncoming()
#7 /usr/share/vitalpbx/www/modules/inbound_route/inbound_route.php(0): modules\inbound_route\Asterisk\DialPlan->build()
#8 /usr/share/vitalpbx/www/includes/OmbuSystemConf.php(0): modules\inbound_route\inbound_route->getDialPlan()
#9 /usr/share/vitalpbx/www/includes/OmbuSystemConf.php(0): vitalpbx\OmbuSystemConf::_ApplyDialPlan()
#10 /usr/share/vitalpbx/scripts/dump_asterisk_conf(0): vitalpbx\OmbuSystemConf::applyConfig()
#11 {main}
  thrown in /usr/share/vitalpbx/www/includes/db.php on line 0

   INFO Nothing to migrate.  

Setting up vitalpbx-sms (4.5.0-3) ...
Setting up vitalpbx-voice-hub (4.5.0-3) ...
Setting up vitalpbx-ai-assistants (4.5.0-7) ...
Setting up vitalpbx-connect (4.5.0-4) ...
Setting up vitalpbx-phones-provisioning (4.5.0-9) ...

   INFO Running migrations.  

  2025_04_24_011336_add_fanvil_v66_model ................................................................................................. 29ms DONE
  2025_05_04_220323_add_expansion_module_to_yealink_t29g_t48g_models ..................................................................... 12ms DONE
  2025_05_08_012135_update_yealink_t27p_keys_count ........................................................................................ 4ms DONE
  2025_06_03_020817_update_grandstream_ht814_model_accounts ............................................................................... 4ms DONE
  2025_06_09_013937_update_fanvil_v_series_models_time_settings ........................................................................... 4ms DONE
  2025_06_10_014228_update_fanvil_v65_keys_count .......................................................................................... 4ms DONE
  2025_06_12_021919_add_fanvil_w610w_model ................................................................................................ 4ms DONE

PHP Fatal error: Uncaught RuntimeException: [404-get] {https://127.0.0.1/provisioning/api/connection-settings}: <html>
<head><title>404 Not Found</title></head>
<body>
<center><h1>404 Not Found</h1></center>
<hr><center>nginx</center>
</body>
</html>
 in /usr/share/vitalpbx/www/includes/components/provisioning/RestClient.php:0
Stack trace:
#0 /usr/share/vitalpbx/www/includes/components/provisioning/RestClient.php(0): provisioning\RestClient->_sendRequest()
#1 /usr/share/vitalpbx/www/includes/components/provisioning/Model.php(0): provisioning\RestClient->Retrieve()
#2 /usr/share/vitalpbx/www/modules/provisioning_connection_settings/ConnectionSettings.php(0): provisioning\Model::GetAll()
#3 /usr/share/vitalpbx/scripts/setup_prov_auth(0): modules\provisioning_connection_settings\ConnectionSettings::all()
#4 {main}
  thrown in /usr/share/vitalpbx/www/includes/components/provisioning/RestClient.php on line 0
Setting up vitalpbx-queues-callback (4.5.0-3) ...
Importing queue_callback.9.sql...
Setting up vitalpbx-phone-books (4.5.0-4) ...
Setting up vitalpbx-multi-tenant (4.5.0-3) ...
Importing mt.1.dids_tbl.sql...
Executing mt.2.migrate_dids.php...
Importing mt.3.remove_deprecated_param.sql...
Importing multi_tenant.sql...
Importing mutli_tenant.20230317.1.update-menu.sql...
Importing mutli_tenant.20230317.2.DID_management.sql...
Importing mutli_tenant.20230317.3.mt_dids_desc.sql...
Importing mutli_tenant.20250626.1.shared_trunks.sql...
Setting up vitalpbx-virtual-faxes (4.5.1-1) ...
Importing fax_11.delivery_method.sql...

```

And this is where it stopped, Switchboard, Stats and many other stuff showed 404.

So I decided to re-install, and run some commands afterwards. See below log, also on pastebin [Logs Part3 - Pastebin.com](https://pastebin.com/4efchT7f)

```bash
root@core1:~# sudo apt-get install --reinstall nginx sonata-switchboard sonata-recordings vitalpbx vitalpbx-sms vitalpbx-voice-hub provisioning-core vitalpbx-ai-assistants sonata-stats vitalpbx-connect vitalpbx-phones-provisioning logger-core sonata-billing vitalpbx-queues-callback vitalpbx-phone-books vitxi vitalpbx-multi-tenant vitalpbx-virtual-faxes
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
The following packages were automatically installed and are no longer required:
  linux-image-5.10.0-33-amd64 linux-image-6.1.0-32-amd64 python3-ntp
Use 'sudo apt autoremove' to remove them.
0 upgraded, 0 newly installed, 18 reinstalled, 0 to remove and 0 not upgraded.
Need to get 0 B/158 MB of archives.
After this operation, 0 B of additional disk space will be used.
(Reading database ... 139288 files and directories currently installed.)
Preparing to unpack .../00-vitalpbx_4.5.1-2_amd64.deb ...
Unpacking vitalpbx (4.5.1-2) over (4.5.1-2) ...
Preparing to unpack .../01-logger-core_4.5.0-3_all.deb ...
Unpacking logger-core (4.5.0-3) over (4.5.0-3) ...
Preparing to unpack .../02-nginx_1.22.1-9+deb12u2_amd64.deb ...
Unpacking nginx (1.22.1-9+deb12u2) over (1.22.1-9+deb12u2) ...
Preparing to unpack .../03-provisioning-core_4.5.0-7_all.deb ...
Unpacking provisioning-core (4.5.0-7) over (4.5.0-7) ...
Preparing to unpack .../04-sonata-billing_4.5.0-2_all.deb ...
Unpacking sonata-billing (4.5.0-2) over (4.5.0-2) ...
Preparing to unpack .../05-sonata-recordings_4.5.0-4_all.deb ...
Unpacking sonata-recordings (4.5.0-4) over (4.5.0-4) ...
Preparing to unpack .../06-sonata-stats_4.0.5-4_all.deb ...
Unpacking sonata-stats (4.0.5-4) over (4.0.5-4) ...
Preparing to unpack .../07-sonata-switchboard_4.5.0-4_all.deb ...
Unpacking sonata-switchboard (4.5.0-4) over (4.5.0-4) ...
Preparing to unpack .../08-vitalpbx-ai-assistants_4.5.0-7_amd64.deb ...
Unpacking vitalpbx-ai-assistants (4.5.0-7) over (4.5.0-7) ...
Preparing to unpack .../09-vitalpbx-connect_4.5.0-4_all.deb ...
Unpacking vitalpbx-connect (4.5.0-4) over (4.5.0-4) ...
Preparing to unpack .../10-vitalpbx-multi-tenant_4.5.0-3_all.deb ...
Unpacking vitalpbx-multi-tenant (4.5.0-3) over (4.5.0-3) ...
Preparing to unpack .../11-vitalpbx-phone-books_4.5.0-4_all.deb ...
Unpacking vitalpbx-phone-books (4.5.0-4) over (4.5.0-4) ...
Preparing to unpack .../12-vitalpbx-phones-provisioning_4.5.0-9_all.deb ...
Unpacking vitalpbx-phones-provisioning (4.5.0-9) over (4.5.0-9) ...
Preparing to unpack .../13-vitalpbx-queues-callback_4.5.0-3_all.deb ...
Unpacking vitalpbx-queues-callback (4.5.0-3) over (4.5.0-3) ...
Preparing to unpack .../14-vitalpbx-sms_4.5.0-3_all.deb ...
Unpacking vitalpbx-sms (4.5.0-3) over (4.5.0-3) ...
Preparing to unpack .../15-vitalpbx-virtual-faxes_4.5.1-1_all.deb ...
Unpacking vitalpbx-virtual-faxes (4.5.1-1) over (4.5.1-1) ...
Preparing to unpack .../16-vitalpbx-voice-hub_4.5.0-3_all.deb ...
Unpacking vitalpbx-voice-hub (4.5.0-3) over (4.5.0-3) ...
Preparing to unpack .../17-vitxi_4.5.0-6_all.deb ...
Unpacking vitxi (4.5.0-6) over (4.5.0-6) ...
Setting up nginx (1.22.1-9+deb12u2) ...
Upgrading binary: nginx.
Setting up sonata-switchboard (4.5.0-4) ...
Setting up sonata-recordings (4.5.0-4) ...

Configuration file '/etc/nginx/pbx-addons/rec-manager.conf'
 ==> File on system created by you or by a script.
 ==> File also in package provided by package maintainer.
   What would you like to do about it ? Your options are:
    Y or I : install the package maintainer's version
    N or O : keep your currently-installed version
      D : show the differences between the versions
      Z : start a shell to examine the situation
 The default action is to keep your current version.
*** rec-manager.conf (Y/I/N/O/D/Z) [default=N] ? Y
Installing new version of config file /etc/nginx/pbx-addons/rec-manager.conf ...
Setting up provisioning-core (4.5.0-7) ...

   INFO Application cache cleared successfully.  

   INFO Clearing cached bootstrap files.  

  events .................................................................................................................................. 3ms DONE
  views .................................................................................................................................. 17ms DONE
  cache .................................................................................................................................. 12ms DONE
  route ................................................................................................................................... 2ms DONE
  config .................................................................................................................................. 2ms DONE
  compiled ................................................................................................................................ 2ms DONE

   INFO Route cache cleared successfully.  

   INFO Caching the framework bootstrap files.  

  config ................................................................................................................................. 32ms DONE
  routes ................................................................................................................................. 25ms DONE

Setting up sonata-stats (4.0.5-4) ...

   INFO Application cache cleared successfully.  

   INFO Clearing cached bootstrap files.  

  events .................................................................................................................................. 4ms DONE
  views .................................................................................................................................. 14ms DONE
  cache ................................................................................................................................... 9ms DONE
  route ................................................................................................................................... 3ms DONE
  config .................................................................................................................................. 2ms DONE
  compiled ................................................................................................................................ 2ms DONE

   INFO Caching the framework bootstrap files.  

  config ................................................................................................................................. 32ms DONE
  routes ................................................................................................................................. 26ms DONE

   INFO Routes cached successfully.  

   INFO Configuration cached successfully.  

   INFO Nothing to migrate.  

Setting up logger-core (4.5.0-3) ...

   INFO Application cache cleared successfully.  

   INFO Clearing cached bootstrap files.  

  cache ................................................................................................................................ 6.20ms DONE
  compiled ............................................................................................................................. 2.95ms DONE
  config ............................................................................................................................... 1.90ms DONE
  events ............................................................................................................................... 1.85ms DONE
  routes ............................................................................................................................... 1.87ms DONE
  views ............................................................................................................................... 17.33ms DONE

   INFO Route cache cleared successfully.  

   INFO Caching framework bootstrap, configuration, and metadata.  

  config .............................................................................................................................. 26.25ms DONE
  events ............................................................................................................................... 2.06ms DONE
  routes .............................................................................................................................. 11.22ms DONE
  views ............................................................................................................................... 44.61ms DONE

Setting up sonata-billing (4.5.0-2) ...

Configuration file '/etc/nginx/pbx-addons/call-accounting.conf'
 ==> File on system created by you or by a script.
 ==> File also in package provided by package maintainer.
   What would you like to do about it ? Your options are:
    Y or I : install the package maintainer's version
    N or O : keep your currently-installed version
      D : show the differences between the versions
      Z : start a shell to examine the situation
 The default action is to keep your current version.
*** call-accounting.conf (Y/I/N/O/D/Z) [default=N] ? Y
Installing new version of config file /etc/nginx/pbx-addons/call-accounting.conf ...
Setting up vitxi (4.5.0-6) ...
Y
Updating 'vitxi' wrapper script...
Starting the .env update process...
Found existing .env file: /usr/share/vitxi/backend/.env
Updating variable DB_CONNECTION to new value mariadb
Updating variable REVERB_APP_ID to new value vitxi_app
Updating variable REVERB_APP_KEY to new value vitxi4561aq
Updating variable REVERB_APP_SECRET to new value va9UMJwqYhs9aKW53FH+asd
Removed empty lines from .env file
Updated .env file has been saved
Restored original permissions, owner, and group to .env file
Temporary file cleaned up
Checking JWT_SECRET and DB_PASSWORD in /usr/share/vitxi/backend/.env...
JWT_SECRET is already set.
DB_PASSWORD is already set.

   INFO Application cache cleared successfully.  

   INFO Caching framework bootstrap, configuration, and metadata.  

  config .............................................................................................................................. 56.32ms DONE
  events ............................................................................................................................... 2.98ms DONE
  routes .............................................................................................................................. 46.76ms DONE
  views ............................................................................................................................... 91.35ms DONE

   INFO Nothing to migrate.  

   INFO Routes cached successfully.  

   INFO Configuration cached successfully.  

   INFO Caching framework bootstrap, configuration, and metadata.  

  config .............................................................................................................................. 59.44ms DONE
  events ............................................................................................................................... 2.23ms DONE
  routes .............................................................................................................................. 42.45ms DONE
  views ............................................................................................................................... 59.71ms DONE

Cron entry already exists in /etc/cron.d/vitxi
Setting up vitalpbx (4.5.1-2) ...
Configuring Tenant: MAIN PBX...

   INFO Nothing to migrate.  

Setting up vitalpbx-sms (4.5.0-3) ...
Setting up vitalpbx-voice-hub (4.5.0-3) ...
Setting up vitalpbx-ai-assistants (4.5.0-7) ...
Setting up vitalpbx-connect (4.5.0-4) ...
Setting up vitalpbx-phones-provisioning (4.5.0-9) ...

   INFO Nothing to migrate.  

💡 [INFO] Configuring Provisioning Auth for "MAIN PBX" tenant...
💡 [INFO] Configuration Applied
💡 [INFO] Done!
Setting up vitalpbx-queues-callback (4.5.0-3) ...
Setting up vitalpbx-phone-books (4.5.0-4) ...
Setting up vitalpbx-multi-tenant (4.5.0-3) ...
Setting up vitalpbx-virtual-faxes (4.5.1-1) ...
Processing triggers for mariadb-server (1:10.11.11-0+deb12u1) ...
Processing triggers for man-db (2.11.2-2) ...
root@core1:~# vitalpbx check-integrity

No Issues Found!

root@core1:~# vitalpbx optimize-mariadb
Restarting MariaDB...
Reloading Asterisk ODBC driver...
Module 'res_odbc.so' reloaded successfully.
Done
● mariadb.service - MariaDB 10.11.11 database server
     Loaded: loaded (/lib/systemd/system/mariadb.service; enabled; preset: enabled)
     Active: active (running) since Thu 2025-07-31 07:12:31 EDT; 101ms ago
       Docs: man:mariadbd(8)
             https://mariadb.com/kb/en/library/systemd/
    Process: 784182 ExecStartPre=/usr/bin/install -m 755 -o mysql -g root -d /var/run/mysqld (code=exited, status=0/SUCCESS)
    Process: 784183 ExecStartPre=/bin/sh -c systemctl unset-environment _WSREP_START_POSITION (code=exited, status=0/SUCCESS)
    Process: 784185 ExecStartPre=/bin/sh -c [! -e /usr/bin/galera_recovery] && VAR= || VAR=`/usr/bin/galera_recovery`; [$? -eq 0] && systemctl set-environment _WSREP_START_POSITION=$VAR || exit 1 (code=exited, status=0/SU> Process: 784349 ExecStartPost=/bin/sh -c systemctl unset-environment _WSREP_START_POSITION (code=exited, status=0/SUCCESS)
    Process: 784351 ExecStartPost=/etc/mysql/debian-start (code=exited, status=0/SUCCESS)
   Main PID: 784326 (mariadbd)
     Status: "Taking your SQL requests now..."
      Tasks: 20 (limit: 62585)
     Memory: 361.9M
        CPU: 1.481s
     CGroup: /system.slice/mariadb.service
             ├─784326 /usr/sbin/mariadbd
             ├─784352 /bin/bash /etc/mysql/debian-start
             ├─784354 /usr/bin/mysql_upgrade --defaults-extra-file=/etc/mysql/debian.cnf --version-check --silent
             ├─784355 grep -E -v "^(1|@had|ERROR (1051|1054|1060|1061|1146|1347|1348))"
             ├─784356 logger -p daemon warn -i -t/etc/mysql/debian-start
             ├─784366 sh -c "'/usr/bin/mariadb' --defaults-file=/tmp/mysql_upgrade-qxanP0 --database=mysql --batch --skip-force --print-query-on-error --silent < /tmp/sqlEFSNC9 2>&1 "
             └─784367 /usr/bin/mariadb --defaults-file=/tmp/mysql_upgrade-qxanP0 --database=mysql --batch --skip-force --print-query-on-error --silent

Jul 31 07:12:30 core1 mariadbd[784326]: 2025-07-31 7:12:30 0 [Note] InnoDB: Setting file './ibtmp1' size to 12.000MiB. Physically writing the file full; Please wait ...
Jul 31 07:12:30 core1 mariadbd[784326]: 2025-07-31 7:12:30 0 [Note] InnoDB: File './ibtmp1' size is now 12.000MiB.
Jul 31 07:12:30 core1 mariadbd[784326]: 2025-07-31 7:12:30 0 [Note] InnoDB: log sequence number 39479775405; transaction id 34977019
Jul 31 07:12:30 core1 mariadbd[784326]: 2025-07-31 7:12:30 0 [Note] InnoDB: Loading buffer pool(s) from /var/lib/mysql/ib_buffer_pool
Jul 31 07:12:30 core1 mariadbd[784326]: 2025-07-31 7:12:30 0 [Note] Plugin 'FEEDBACK' is disabled.
Jul 31 07:12:31 core1 mariadbd[784326]: 2025-07-31 7:12:31 0 [Note] Server socket created on IP: '0.0.0.0'.
Jul 31 07:12:31 core1 mariadbd[784326]: 2025-07-31 7:12:31 0 [Note] Server socket created on IP: '::'.
Jul 31 07:12:31 core1 mariadbd[784326]: 2025-07-31 7:12:31 0 [Note] /usr/sbin/mariadbd: ready for connections.
Jul 31 07:12:31 core1 mariadbd[784326]: Version: '10.11.11-MariaDB-0+deb12u1-log' socket: '/run/mysqld/mysqld.sock' port: 3306 Debian 12
Jul 31 07:12:31 core1 systemd[1]: Started mariadb.service - MariaDB 10.11.11 database server.
root@core1:~# vitalpbx optimize-server
Optimizing Nginx...
Optimizing PHP FPM...
Optimizing MariaDB...
Optimizing Redis...
Optimizing Server...
Module 'res_odbc.so' reloaded successfully.
Done
● nginx.service - A high performance web server and a reverse proxy server
     Loaded: loaded (/lib/systemd/system/nginx.service; enabled; preset: enabled)
     Active: active (running) since Thu 2025-07-31 07:13:31 EDT; 3s ago
       Docs: man:nginx(8)
    Process: 784717 ExecStartPre=/usr/sbin/nginx -t -q -g daemon on; master_process on; (code=exited, status=0/SUCCESS)
    Process: 784718 ExecStart=/usr/sbin/nginx -g daemon on; master_process on; (code=exited, status=0/SUCCESS)
   Main PID: 784719 (nginx)
      Tasks: 7 (limit: 9482)
     Memory: 8.4M
        CPU: 199ms
     CGroup: /system.slice/nginx.service
             ├─784719 "nginx: master process /usr/sbin/nginx -g daemon on; master_process on;"
             ├─784720 "nginx: worker process"
             ├─784721 "nginx: worker process"
             ├─784722 "nginx: worker process"
             ├─784723 "nginx: worker process"
             ├─784724 "nginx: worker process"
             └─784725 "nginx: worker process"

Jul 31 07:13:31 core1 systemd[1]: Starting nginx.service - A high performance web server and a reverse proxy server...
Jul 31 07:13:31 core1 systemd[1]: Started nginx.service - A high performance web server and a reverse proxy server.
● php8.2-fpm.service - The PHP 8.2 FastCGI Process Manager
     Loaded: loaded (/lib/systemd/system/php8.2-fpm.service; enabled; preset: enabled)
     Active: active (running) since Thu 2025-07-31 07:13:25 EDT; 8s ago
       Docs: man:php-fpm8.2(8)
    Process: 784699 ExecStartPost=/usr/lib/php/php-fpm-socket-helper install /run/php/php-fpm.sock /etc/php/8.2/fpm/pool.d/www.conf 82 (code=exited, status=0/SUCCESS)
   Main PID: 784666 (php-fpm8.2)
     Status: "Ready to handle connections"
      Tasks: 31 (limit: 9482)
     Memory: 35.9M
        CPU: 740ms
     CGroup: /system.slice/php8.2-fpm.service
             ├─784666 "php-fpm: master process (/etc/php/8.2/fpm/php-fpm.conf)"
             ├─784669 "php-fpm: pool www"
             ├─784670 "php-fpm: pool www"
             ├─784671 "php-fpm: pool www"
             ├─784672 "php-fpm: pool www"
             ├─784673 "php-fpm: pool www"
             ├─784674 "php-fpm: pool www"
             ├─784675 "php-fpm: pool www"
             ├─784676 "php-fpm: pool www"
             ├─784677 "php-fpm: pool www"
             ├─784678 "php-fpm: pool www"
             ├─784679 "php-fpm: pool www"
             ├─784680 "php-fpm: pool www"
             ├─784681 "php-fpm: pool www"
             ├─784682 "php-fpm: pool www"
             ├─784683 "php-fpm: pool www"
             ├─784684 "php-fpm: pool www"
             ├─784685 "php-fpm: pool www"
             ├─784686 "php-fpm: pool www"
             ├─784687 "php-fpm: pool www"
             ├─784688 "php-fpm: pool www"
             ├─784689 "php-fpm: pool www"
             ├─784690 "php-fpm: pool www"
             ├─784691 "php-fpm: pool www"
             ├─784692 "php-fpm: pool www"
             ├─784693 "php-fpm: pool www"
             ├─784694 "php-fpm: pool www"
             ├─784695 "php-fpm: pool www"
             ├─784696 "php-fpm: pool www"
             ├─784697 "php-fpm: pool www"
             └─784698 "php-fpm: pool www"

Jul 31 07:13:25 core1 systemd[1]: Starting php8.2-fpm.service - The PHP 8.2 FastCGI Process Manager...
Jul 31 07:13:25 core1 systemd[1]: Started php8.2-fpm.service - The PHP 8.2 FastCGI Process Manager.
● mariadb.service - MariaDB 10.11.11 database server
     Loaded: loaded (/lib/systemd/system/mariadb.service; enabled; preset: enabled)
     Active: active (running) since Thu 2025-07-31 07:13:33 EDT; 1s ago
       Docs: man:mariadbd(8)
             https://mariadb.com/kb/en/library/systemd/
    Process: 784729 ExecStartPre=/usr/bin/install -m 755 -o mysql -g root -d /var/run/mysqld (code=exited, status=0/SUCCESS)
    Process: 784730 ExecStartPre=/bin/sh -c systemctl unset-environment _WSREP_START_POSITION (code=exited, status=0/SUCCESS)
    Process: 784732 ExecStartPre=/bin/sh -c [! -e /usr/bin/galera_recovery] && VAR= || VAR=`/usr/bin/galera_recovery`; [$? -eq 0] && systemctl set-environment _WSREP_START_POSITION=$VAR || exit 1 (code=exited, status=0/SU> Process: 784885 ExecStartPost=/bin/sh -c systemctl unset-environment _WSREP_START_POSITION (code=exited, status=0/SUCCESS)
    Process: 784887 ExecStartPost=/etc/mysql/debian-start (code=exited, status=0/SUCCESS)
   Main PID: 784872 (mariadbd)
     Status: "Taking your SQL requests now..."
      Tasks: 15 (limit: 62585)
     Memory: 313.7M
        CPU: 2.186s
     CGroup: /system.slice/mariadb.service
             └─784872 /usr/sbin/mariadbd

Jul 31 07:13:32 core1 mariadbd[784872]: 2025-07-31 7:13:32 0 [Note] Plugin 'FEEDBACK' is disabled.
Jul 31 07:13:32 core1 mariadbd[784872]: 2025-07-31 7:13:32 0 [Note] InnoDB: Buffer pool(s) load completed at 250731 7:13:32
Jul 31 07:13:33 core1 mariadbd[784872]: 2025-07-31 7:13:33 0 [Note] Server socket created on IP: '0.0.0.0'.
Jul 31 07:13:33 core1 mariadbd[784872]: 2025-07-31 7:13:33 0 [Note] Server socket created on IP: '::'.
Jul 31 07:13:33 core1 mariadbd[784872]: 2025-07-31 7:13:33 0 [Note] /usr/sbin/mariadbd: ready for connections.
Jul 31 07:13:33 core1 mariadbd[784872]: Version: '10.11.11-MariaDB-0+deb12u1-log' socket: '/run/mysqld/mysqld.sock' port: 3306 Debian 12
Jul 31 07:13:33 core1 systemd[1]: Started mariadb.service - MariaDB 10.11.11 database server.
Jul 31 07:13:33 core1 /etc/mysql/debian-start[784889]: Upgrading MySQL tables if necessary.
Jul 31 07:13:33 core1 /etc/mysql/debian-start[784902]: Checking for insecure root accounts.
Jul 31 07:13:33 core1 /etc/mysql/debian-start[784906]: Triggering myisam-recover for all MyISAM tables and aria-recover for all Aria tables
● redis-server.service - Advanced key-value store
     Loaded: loaded (/lib/systemd/system/redis-server.service; enabled; preset: enabled)
     Active: active (running) since Thu 2025-07-31 07:13:34 EDT; 2s ago
       Docs: http://redis.io/documentation,
             man:redis-server(1)
   Main PID: 784923 (redis-server)
     Status: "Ready to accept connections"
      Tasks: 5 (limit: 9482)
     Memory: 24.1M
        CPU: 615ms
     CGroup: /system.slice/redis-server.service
             └─784923 "/usr/bin/redis-server 127.0.0.1:6379"

Jul 31 07:13:33 core1 systemd[1]: Starting redis-server.service - Advanced key-value store...
Jul 31 07:13:34 core1 systemd[1]: Started redis-server.service - Advanced key-value store.
root@core1:~# vitalpbx gen-conf
Done
root@core1:~# vitalpbx fully-gen-conf
Configuring Tenant: MAIN PBX...
Done

```

Switchboard, Stats etc started working now.

* * *

So the burning question here is, what ELSE is broken, is there anything else that needs to be repaired, changed or reinstalled?

Thanks

---

<div class="post-metadata">

### Author: ![PitzKey](https://forums.vitalpbx.org/user_avatar/forums.vitalpbx.org/pitzkey/32/420_2.png) [@PitzKey](https://forums.vitalpbx.org/u/PitzKey)
#### Post date: [July 31, 2025, 11:30am UTC](https://forums.vitalpbx.org/t/broken-update-to-4-5-1-2/5612/2 "2025-07-31T11:30:58Z")

</div>

In addition to that `vitalpbx-connect` as well as some other packages were previously not installed, not sure why it got installed now.

---

<div class="post-metadata">

### Author: ![Unified](https://forums.vitalpbx.org/letter_avatar_proxy/v4/letter/u/7cd45c/32.png) [@Unified](https://forums.vitalpbx.org/u/Unified)
#### Post date: [August 21, 2025, 1:49pm UTC](https://forums.vitalpbx.org/t/broken-update-to-4-5-1-2/5612/3 "2025-08-21T13:49:02Z")

</div>

I had the same issue.  
@PitzKey helped me fix it.  
I have three other systems I need to update but I’m holding off until there’s a fix.

---

<div class="post-metadata">

### Author: ![miguel](https://forums.vitalpbx.org/user_avatar/forums.vitalpbx.org/miguel/32/415_2.png) [@miguel](https://forums.vitalpbx.org/u/miguel)
#### Post date: [August 21, 2025, 3:37pm UTC](https://forums.vitalpbx.org/t/broken-update-to-4-5-1-2/5612/4 "2025-08-21T15:37:07Z")

</div>

Do the following:

```auto
sed -i 's|include /etc/nginx/pbx-addons/\*;|include /etc/nginx/pbx-addons/*.conf;|' /etc/nginx/sites-enabled/vitalpbx

```

Then

```auto
dpkg --configure -a
apt-get --reinstall install logger-core -y
systemctl restart nginx

```

---

<div class="post-metadata">

### Author: ![miguel](https://forums.vitalpbx.org/user_avatar/forums.vitalpbx.org/miguel/32/415_2.png) [@miguel](https://forums.vitalpbx.org/u/miguel)
#### Post date: [August 21, 2025, 3:38pm UTC](https://forums.vitalpbx.org/t/broken-update-to-4-5-1-2/5612/5 "2025-08-21T15:38:33Z")

</div>

The command below, can be executed before updating to VitalPBX 4.5.1 to avoid issues during the upgrade.

```auto
sed -i 's|include /etc/nginx/pbx-addons/\*;|include /etc/nginx/pbx-addons/*.conf;|' /etc/nginx/sites-enabled/vitalpbx

```

---

<div class="post-metadata">

### Author: ![Unified](https://forums.vitalpbx.org/letter_avatar_proxy/v4/letter/u/7cd45c/32.png) [@Unified](https://forums.vitalpbx.org/u/Unified)
#### Post date: [August 21, 2025, 3:50pm UTC](https://forums.vitalpbx.org/t/broken-update-to-4-5-1-2/5612/6 "2025-08-21T15:50:05Z")

</div>

Thank you.  
Greatly appreciated.

---

<div class="post-metadata">

### Author: ![Unified](https://forums.vitalpbx.org/letter_avatar_proxy/v4/letter/u/7cd45c/32.png) [@Unified](https://forums.vitalpbx.org/u/Unified)
#### Post date: [August 21, 2025, 4:06pm UTC](https://forums.vitalpbx.org/t/broken-update-to-4-5-1-2/5612/7 "2025-08-21T16:06:55Z")

</div>

I got this error on the next machine after running the sed command

```auto
Setting up vitalpbx-phones-provisioning (4.5.1-1) ...

   INFO Running migrations.

  2025_03_11_022248_add_expansion_module_to_yealink_t58a_model ........................................................................... 12ms DONE
  2025_04_24_011336_add_fanvil_v66_model .................................................................................................. 3ms DONE
  2025_05_04_220323_add_expansion_module_to_yealink_t29g_t48g_models ...................................................................... 3ms DONE
  2025_05_08_012135_update_yealink_t27p_keys_count ........................................................................................ 1ms DONE
  2025_06_03_020817_update_grandstream_ht814_model_accounts ............................................................................... 1ms DONE
  2025_06_09_013937_update_fanvil_v_series_models_time_settings ........................................................................... 1ms DONE
  2025_06_10_014228_update_fanvil_v65_keys_count .......................................................................................... 1ms DONE
  2025_06_12_021919_add_fanvil_w610w_model ................................................................................................ 1ms DONE

PHP Fatal error: Uncaught RuntimeException: [404-get] {https://127.0.0.1/provisioning/api/connection-settings}: <html>
<head><title>404 Not Found</title></head>
<body>
<center><h1>404 Not Found</h1></center>
<hr><center>nginx/1.22.1</center>
</body>
</html>
 in /usr/share/vitalpbx/www/includes/components/provisioning/RestClient.php:0
Stack trace:
#0 /usr/share/vitalpbx/www/includes/components/provisioning/RestClient.php(0): provisioning\RestClient->_sendRequest()
#1 /usr/share/vitalpbx/www/includes/components/provisioning/Model.php(0): provisioning\RestClient->Retrieve()
#2 /usr/share/vitalpbx/www/modules/provisioning_connection_settings/ConnectionSettings.php(0): provisioning\Model::GetAll()
#3 /usr/share/vitalpbx/scripts/setup_prov_auth(0): modules\provisioning_connection_settings\ConnectionSettings::all()
#4 {main}
  thrown in /usr/share/vitalpbx/www/includes/components/provisioning/RestClient.php on line 0
Setting up vitalpbx-phone-books (4.5.0-4) ...
Processing triggers for systemd (252.38-1~deb12u1) ...
Processing triggers for man-db (2.11.2-2) ...
Processing triggers for mariadb-server (1:10.11.11-0+deb12u1) ...
Processing triggers for dbus (1.14.10-1~deb12u1) ...
Processing triggers for debianutils (5.7-0.5~deb12u1) ...
Processing triggers for mailcap (3.70+nmu1) ...
Processing triggers for libc-bin (2.36-9+deb12u10) ...
Processing triggers for initramfs-tools (0.142+deb12u3) ...
update-initramfs: Generating /boot/initrd.img-6.1.0-38-amd64
Processing triggers for ca-certificates (20230311+deb12u1) ...
Updating certificates in /etc/ssl/certs...
0 added, 0 removed; done.
Running hooks in /etc/ca-certificates/update.d...
done.
Processing triggers for php8.2-cli (8.2.29-1~deb12u1) ...
Processing triggers for php8.2-fpm (8.2.29-1~deb12u1) ...

```

---

<div class="post-metadata">

### Author: ![miguel](https://forums.vitalpbx.org/user_avatar/forums.vitalpbx.org/miguel/32/415_2.png) [@miguel](https://forums.vitalpbx.org/u/miguel)
#### Post date: [August 21, 2025, 4:07pm UTC](https://forums.vitalpbx.org/t/broken-update-to-4-5-1-2/5612/8 "2025-08-21T16:07:58Z")

</div>

You must run the command and then update the PBX.

---

<div class="post-metadata">

### Author: ![Unified](https://forums.vitalpbx.org/letter_avatar_proxy/v4/letter/u/7cd45c/32.png) [@Unified](https://forums.vitalpbx.org/u/Unified)
#### Post date: [August 21, 2025, 4:08pm UTC](https://forums.vitalpbx.org/t/broken-update-to-4-5-1-2/5612/9 "2025-08-21T16:08:41Z")

</div>

That’s what I did

```auto
root@vitalpbx:~# sed -i 's|include /etc/nginx/pbx-addons/\*;|include /etc/nginx/ pbx-addons/*.conf;|' /etc/nginx/sites-enabled/vitalpbx
root@vitalpbx:~# apt update

```

---

<div class="post-metadata">

### Author: ![Unified](https://forums.vitalpbx.org/letter_avatar_proxy/v4/letter/u/7cd45c/32.png) [@Unified](https://forums.vitalpbx.org/u/Unified)
#### Post date: [August 21, 2025, 4:11pm UTC](https://forums.vitalpbx.org/t/broken-update-to-4-5-1-2/5612/10 "2025-08-21T16:11:33Z")

</div>

I missed and then “apt upgrade”

---

<div class="post-metadata">

### Author: ![miguel](https://forums.vitalpbx.org/user_avatar/forums.vitalpbx.org/miguel/32/415_2.png) [@miguel](https://forums.vitalpbx.org/u/miguel)
#### Post date: [August 21, 2025, 4:12pm UTC](https://forums.vitalpbx.org/t/broken-update-to-4-5-1-2/5612/11 "2025-08-21T16:12:08Z")

</div>

The `apt update` just update the repo and the package that are available for updating.

Here are all the steps to update.

```auto
apt clean all
apt update
apt upgrade -y

```

---

<div class="post-metadata">

### Author: ![Unified](https://forums.vitalpbx.org/letter_avatar_proxy/v4/letter/u/7cd45c/32.png) [@Unified](https://forums.vitalpbx.org/u/Unified)
#### Post date: [August 21, 2025, 4:16pm UTC](https://forums.vitalpbx.org/t/broken-update-to-4-5-1-2/5612/12 "2025-08-21T16:16:17Z")

</div>

Yes I ran “apt clean all” beforehand.  
This upgrade was a lot cleaner then the first and everything seems to be working.  
My only concern is the error that occurred during the update.

```auto
PHP Fatal error: Uncaught RuntimeException: [404-get] {https://127.0.0.1/provisioning/api/connection-settings}: <html>
<head><title>404 Not Found</title></head>
<body>
<center><h1>404 Not Found</h1></center>
<hr><center>nginx/1.22.1</center>
</body>
</html>
 in /usr/share/vitalpbx/www/includes/components/provisioning/RestClient.php:0
Stack trace:
#0 /usr/share/vitalpbx/www/includes/components/provisioning/RestClient.php(0): provisioning\RestClient->_sendRequest()
#1 /usr/share/vitalpbx/www/includes/components/provisioning/Model.php(0): provisioning\RestClient->Retrieve()
#2 /usr/share/vitalpbx/www/modules/provisioning_connection_settings/ConnectionSettings.php(0): provisioning\Model::GetAll()
#3 /usr/share/vitalpbx/scripts/setup_prov_auth(0): modules\provisioning_connection_settings\ConnectionSettings::all()
#4 {main}
  thrown in /usr/share/vitalpbx/www/includes/components/provisioning/RestClient.php on line 0

```

---

<div class="post-metadata">

### Author: ![miguel](https://forums.vitalpbx.org/user_avatar/forums.vitalpbx.org/miguel/32/415_2.png) [@miguel](https://forums.vitalpbx.org/u/miguel)
#### Post date: [August 21, 2025, 4:42pm UTC](https://forums.vitalpbx.org/t/broken-update-to-4-5-1-2/5612/13 "2025-08-21T16:42:57Z")

</div>

```auto
apt-get --reinstall install provisioning-core -y
systemctl restart nginx

```

---

<div class="post-metadata">

### Author: ![PitzKey](https://forums.vitalpbx.org/user_avatar/forums.vitalpbx.org/pitzkey/32/420_2.png) [@PitzKey](https://forums.vitalpbx.org/u/PitzKey)
#### Post date: [August 21, 2025, 4:46pm UTC](https://forums.vitalpbx.org/t/broken-update-to-4-5-1-2/5612/14 "2025-08-21T16:46:56Z")

</div>

Miguel,

The question is, why wasn’t the repos updated with a fix to prevent this from happening?

This has been reported 3 weeks ago… It’s still an issue.

---

<div class="post-metadata">

### Author: ![miguel](https://forums.vitalpbx.org/user_avatar/forums.vitalpbx.org/miguel/32/415_2.png) [@miguel](https://forums.vitalpbx.org/u/miguel)
#### Post date: [August 21, 2025, 4:48pm UTC](https://forums.vitalpbx.org/t/broken-update-to-4-5-1-2/5612/15 "2025-08-21T16:48:38Z")

</div>

You must run the command below before updating to VitalPBX 4.5.1 or hold the NGINX package, so it doesn’t mess the PBX installation.

```auto
sed -i 's|include /etc/nginx/pbx-addons/\*;|include /etc/nginx/pbx-addons/*.conf;|' /etc/nginx/sites-enabled/vitalpbx

```

---

<div class="post-metadata">

### Author: ![PitzKey](https://forums.vitalpbx.org/user_avatar/forums.vitalpbx.org/pitzkey/32/420_2.png) [@PitzKey](https://forums.vitalpbx.org/u/PitzKey)
#### Post date: [August 21, 2025, 6:03pm UTC](https://forums.vitalpbx.org/t/broken-update-to-4-5-1-2/5612/16 "2025-08-21T18:03:43Z")

</div>

Yeah, why don’t you include that command in the update?

---

<div class="post-metadata">

### Author: ![miguel](https://forums.vitalpbx.org/user_avatar/forums.vitalpbx.org/miguel/32/415_2.png) [@miguel](https://forums.vitalpbx.org/u/miguel)
#### Post date: [August 21, 2025, 6:58pm UTC](https://forums.vitalpbx.org/t/broken-update-to-4-5-1-2/5612/17 "2025-08-21T18:58:57Z")

</div>

Because it won’t be executed earlier enough to fix the issue!

---

<div class="post-metadata">

### Author: ![mo10](https://forums.vitalpbx.org/letter_avatar_proxy/v4/letter/m/58f4c7/32.png) [@mo10](https://forums.vitalpbx.org/u/mo10)
#### Post date: [August 22, 2025, 1:34pm UTC](https://forums.vitalpbx.org/t/broken-update-to-4-5-1-2/5612/18 "2025-08-22T13:34:16Z")

</div>

So everyone need to be afraid of an update now and from now on?

---

<div class="post-metadata">

### Author: ![miguel](https://forums.vitalpbx.org/user_avatar/forums.vitalpbx.org/miguel/32/415_2.png) [@miguel](https://forums.vitalpbx.org/u/miguel)
#### Post date: [August 22, 2025, 2:16pm UTC](https://forums.vitalpbx.org/t/broken-update-to-4-5-1-2/5612/19 "2025-08-22T14:16:52Z")

</div>

That’s the only breaking change if you are running version previous to v4.5.1.

---

<div class="post-metadata">

### Author: ![PitzKey](https://forums.vitalpbx.org/user_avatar/forums.vitalpbx.org/pitzkey/32/420_2.png) [@PitzKey](https://forums.vitalpbx.org/u/PitzKey)
#### Post date: [August 23, 2025, 9:25pm UTC](https://forums.vitalpbx.org/t/broken-update-to-4-5-1-2/5612/20 "2025-08-23T21:25:19Z")

</div>

Indeed. But I did not see an email, a banner, or a warning when upgrading that this may happen.

Sorry, but this was very poorly communicated and not taken serious.

[Next page](https://forums.vitalpbx.org/t/broken-update-to-4-5-1-2/5612.md?page=2)
